sicily 1024. Magic Island

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

There are N cities and N-1 roads in Magic-Island. You can go from one city to any other. One road only connects two cities. One day, The king of magic-island want to visit the island from the capital. No road is visited twice. Do you know the longest distance the king can go.

Input

There are several test cases in the input
A test case starts with two numbers N and K. (1<=N<=10000, 1<=K<=N). The cities is denoted from 1 to N. K is the capital.

The next N-1 lines each contain three numbers X, Y, D, meaning that there is a road between city-X and city-Y and the distance of the road is D. D is a positive integer which is not bigger than 1000.
Input will be ended by the end of file.

Output

One number per line for each test case, the longest distance the king can go.

Sample Input

3 1
1 2 10
1 3 20

Sample Output

20

以前做的题,加了点注释

#include<cstdio>
#include<vector>
using namespace std;
#define MAX 10001
struct road {
    int id;  // id of the road
    int end; // another end
    int len;
    road(int i, int e, int l) {
        id = i, end = e; len = l;
    }
};

bool visited[MAX];  // has road id been visited
                    // can't use attr since the road is bidirenctional,
                    // whereas visiting is one-direnctional => unnecessary search
int maxLen;
vector<road> roads[MAX];

void dfs(int start, int total = 0) {
    // for each road connected to start
    for (int i = 0; i < roads[start].size(); i++) {
        // if it hasn't been visited
        if (!visited[roads[start][i].id]) {
            // visit it
            visited[roads[start][i].id] = true;
            total += roads[start][i].len;
             
            // upadate
            if (maxLen < total) 
                maxLen = total;
 
             // start from its other end
            dfs(roads[start][i].end, total);
            
            // [IMPORTANT] backtracking
            total -= roads[start][i].len;
            visited[roads[start][i].id] = false;
        }
    }
}

int main() {
    int start, end, len;
    int n, k;
    while(scanf("%d%d", &n, &k) != EOF) {
        // initialize
        for (int i = 0; i < MAX; i++) {
            roads[i].clear();
            visited[i] = false;
        }

        for (int i = 1; i < n; i++) {
            scanf("%d%d%d", &start, &end, &len);
            // bidirenctional
            roads[start].push_back(road(i, end, len));
            roads[end].push_back(road(i, start, len));
        }
        
        maxLen = 0;
        dfs(k);
        printf("%d\n", maxLen);
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/joyeecheung/p/3505124.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值