[sicily online]1024. Magic Island

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

There are N cities and N-1 roads in Magic-Island. You can go from one city to any other. One road only connects two cities. One day, The king of magic-island want to visit the island from the capital. No road is visited twice. Do you know the longest distance the king can go.

Input

There are several test cases in the input
A test case starts with two numbers N and K. (1<=N<=10000, 1<=K<=N). The cities is denoted from 1 to N. K is the capital.

The next N-1 lines each contain three numbers XYD, meaning that there is a road between city-X and city-Y and the distance of the road is D. D is a positive integer which is not bigger than 1000.
Input will be ended by the end of file.

Output

One number per line for each test case, the longest distance the king can go.

Sample Input

3 1
1 2 10
1 3 20

Sample Output

20

分析:

我是用队列实现的广度优先,时间是0.4s,但是别人用深度优先就0.15s,必须把所有叶子节点都遍历到啊,为什么时间会差这么多呢。。

#include<iostream>
#include <iomanip>
#include<stdio.h>
#include<cmath>
#include<iomanip>
#include<list>
#include <map>
#include <vector>
#include <string>
#include <algorithm>
#include <sstream>
#include <stack>
#include<queue>
#include<string.h>
using namespace std;


typedef struct NODE
{
	int distanceTotal;
	bool flag;
	vector<struct LINE> child;//line看不到
}node;

typedef struct LINE
{
	int another;
	int value;
}line;

int main()
{
	int n,root;
	while(scanf("%d%d",&n,&root)!=EOF)
	{
		root--;//以0开始
		map<int,node> gra;
		for(int i=0;i<n-1;i++)
		{//初始化图
			int row,col,distance;
			//cin>>row>>col>>distance;
			scanf("%d%d%d",&row,&col,&distance);
			row--;
			col--;
			line li1={col,distance};
			line li2={row,distance};
			gra[row].child.push_back(li1);
			gra[row].distanceTotal=0;
			gra[row].flag=false;
			gra[col].child.push_back(li2);
			gra[col].distanceTotal=0;
			gra[col].flag=false;
		}//end for i

		queue<int> qu;//用队列,广度优先
		qu.push(root);
		gra[root].flag=true;
		int max=0;
		while(!qu.empty())
		{
			int index=qu.front();
			gra[index].flag=true;
			qu.pop();
			for(vector<line>::iterator ite=gra[index].child.begin();ite!=gra[index].child.end();ite++)
			{
				if(gra[ite->another].flag)
					continue;
				gra[ite->another].distanceTotal=gra[index].distanceTotal+ite->value;
				if(gra[ite->another].child.size()==1)
				{
					if(max<gra[ite->another].distanceTotal)
						max=gra[ite->another].distanceTotal;
				}
				else qu.push(ite->another);
			}
		}//end while
		cout<<max<<endl;
	}//end while cin
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值