poj 3468(线段树,区间加减,延迟操作)

  A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 36129 Accepted: 10381
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.
#include<stdio.h>
#define maxn 100000
__int64 ans;
struct node
{
    int left,right;
    __int64 sum,lazy;
    int mid()
    {
        return (left+right)>>1;
    }
}tree[maxn*4];
void pushdown(int rt,int len)
{
    if(tree[rt].lazy)
    {
        tree[rt<<1].lazy+=tree[rt].lazy;
        tree[rt<<1|1].lazy+=tree[rt].lazy;
        tree[rt<<1].sum+=(tree[rt].lazy*(len-(len>>1)));
        tree[rt<<1|1].sum+=(tree[rt].lazy*(len>>1));
        tree[rt].lazy=0;
    }
}
void btree(int left,int right,int rt)
{
    tree[rt].lazy=0;
    tree[rt].left=left;
    tree[rt].right=right;
    if(left==right)
    {
        scanf("%I64d",&tree[rt].sum);
        return;
    }
    int mid=tree[rt].mid();
    btree(left,mid,rt<<1);
    btree(mid+1,right,rt<<1|1);
    tree[rt].sum=tree[rt<<1].sum+tree[rt<<1|1].sum;
}
void update(int left,int right,int rt,int L,int R,__int64 val)
{
    if(L<=left&&right<=R)
    {
        tree[rt].lazy+=val;
        tree[rt].sum+=(right-left+1)*val;
        return;
    }
    int mid=tree[rt].mid();
    pushdown(rt,right-left+1);
    int len=(right-left)+1;
    if(L<=mid)
        update(left,mid,rt<<1,L,R,val);
    if(R>mid)
        update(mid+1,right,rt<<1|1,L,R,val);
    tree[rt].sum=tree[rt<<1].sum+tree[rt<<1|1].sum;
}
void query(int left,int right,int rt,int L,int R)
{
    if(L<=left&&right<=R)
    {
        ans+=tree[rt].sum;
        return ;
    }
    int mid=tree[rt].mid();
    pushdown(rt,right-left+1);
    if(R<=mid)
    {
        query(left,mid,rt<<1,L,R);
    }
    else if(L>mid)
    {
        query(mid+1,right,rt<<1|1,L,R);
    }
    else
    {
        query(left,mid,rt<<1,L,R);
        query(mid+1,right,rt<<1|1,L,R);
    }
    
}
int main()
{
    int n,q,i;
    int a,b;
    __int64    val;
    char str[5];
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        btree(1,n,1);
        for(i=1;i<=q;i++)
        {
            scanf("%s%d%d",str,&a,&b);
            if(str[0]=='Q')
            {
                ans=0;;
                query(1,n,1,a,b);
                printf("%I64d\n",ans);
            }
            else
            {
                scanf("%I64d",&val);
                update(1,n,1,a,b,val);
            }
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/M-cag/archive/2012/09/14/2685504.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值