[洛谷P3501] [POI2010]ANT-Antisymmetry

洛谷题目链接:[POI2010]ANT-Antisymmetry

题目描述

Byteasar studies certain strings of zeroes and ones.

Let ant-en-tex.1.png be such a string. By ant-en-tex.2.png we will denote the reversed (i.e., "read backwards") string ant-en-tex.3.png, and by ant-en-tex.4.png we will denote the string obtained from ant-en-tex.5.png by changing all the zeroes to ones and ones to zeroes.

Byteasar is interested in antisymmetry, while all things symmetric bore him.

Antisymmetry however is not a mere lack of symmetry.

We will say that a (nonempty) string ant-en-tex.6.png is antisymmetric if, for every position ant-en-tex.7.png in ant-en-tex.8.png, the ant-en-tex.9.png-th last character is different than the ant-en-tex.10.png-th (first) character.

In particular, a string ant-en-tex.11.png consisting of zeroes and ones is antisymmetric if and only if ant-en-tex.12.png.

For example, the strings 00001111 and 010101 are antisymmetric, while 1001 is not.

In a given string consisting of zeroes and ones we would like to determine the number of contiguous nonempty antisymmetric fragments.

Different fragments corresponding to the same substrings should be counted multiple times.

对于一个01字符串,如果将这个字符串0和1取反后,再将整个串反过来和原串一样,就称作“反对称”字符串。比如00001111和010101就是反对称的,1001就不是。

现在给出一个长度为N的01字符串,求它有多少个子串是反对称的。

输入输出格式

输入格式:

The first line of the standard input contains an integer
ant-en-tex.13.png (ant-en-tex.14.png) that denotes the length of the string.

The second line gives a string of 0 and/or 1 of length ant-en-tex.15.png.

There are no spaces in the string.

输出格式:

The first and only line of the standard output should contain a single integer, namely the number of contiguous (non empty) fragments of the given string that are antisymmetric.

输入输出样例

输入样例#1:

8
11001011

输出样例#1:

7

说明

7个反对称子串分别是:01(出现两次),10(出现两次),0101,1100和001011

简述一下题意: 给出一个01串,要求出其中反对称的回文字串的个数(就是将该字串反转后每一位都不相同).

因为要求回文串的个数,所以我们可以考虑用manacher来做.我们知道,manacher算法是用来求最长回文的.那么我们要怎么样才能求出回文个数呢?其实很简单,就在处理回文串半径的时候将每个回文的半径都加入答案中就可以了.另外要注意一下只能记录长度为偶数的回文字串,因为如果是奇数长度的回文串一定不满足题意(想一下为什么).

#include<bits/stdc++.h>
using namespace std;
const int N=10000000+5;
typedef long long lol;

int n, cnt, p[N*2];
lol ans = 0;
char s[N], ss[N*2], c[1000];

void init(){
    cnt = 1; ss[0] = '$', ss[cnt] = '#';
    for(int i=1;i<=n;i++)
    ss[++cnt] = s[i], ss[++cnt] = '#';
    c['0'] = '1', c['1'] = '0', c['#'] = '#';
    ss[cnt+1] = '*';
}

void manacher(){
    int id = 0, mx = 0;
    for(int i=1;i<=cnt;i++){
    if(i <= mx) p[i] = min(p[id*2-i],mx-i);
    else p[i] = 1;
    while(ss[i+p[i]] == c[ss[i-p[i]]]) p[i]++;
    if(mx < i+p[i]) mx = i+p[i], id = i;
    }
    for(int i=1;i<=cnt;i+=2)
    ans += (p[i]-1)/2;
}

int main(){
    //freopen("ghost.in","r",stdin);
    //freopen("ghost.out","w",stdout);
    cin >> n; scanf("%s",s+1);
    init(); manacher();
    printf("%lld\n",ans);
    return 0;
}

转载于:https://www.cnblogs.com/BCOI/p/8973776.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值