POI2010:ANT-Antisymmetry(二分 + HASH)

题目描述

Byteasar studies certain strings of zeroes and ones.

Let  be such a string. By  we will denote the reversed (i.e., "read backwards") string , and by  we will denote the string obtained from  by changing all the zeroes to ones and ones to zeroes.

Byteasar is interested in antisymmetry, while all things symmetric bore him.

Antisymmetry however is not a mere lack of symmetry.

We will say that a (nonempty) string  is antisymmetric if, for every position  in , the -th last character is different than the -th (first) character.

In particular, a string  consisting of zeroes and ones is antisymmetric if and only if .

For example, the strings 00001111 and 010101 are antisymmetric, while 1001 is not.

In a given string consisting of zeroes and ones we would like to determine the number of contiguous nonempty antisymmetric fragments.

Different fragments corresponding to the same substrings should be counted multiple times.

对于一个01字符串,如果将这个字符串0和1取反后,再将整个串反过来和原串一样,就称作“反对称”字符串。比如00001111和010101就是反对称的,1001就不是。

现在给出一个长度为N的01字符串,求它有多少个子串是反对称的。

输入输出格式

输入格式:

 

The first line of the standard input contains an integer  () that denotes the length of the string.

The second line gives a string of 0 and/or 1 of length .

There are no spaces in the string.

 

输出格式:

 

The first and only line of the standard output should contain a single integer, namely the number of contiguous (non empty) fragments of the given string that are antisymmetric.

 

输入输出样例

输入样例#1: 复制

8
11001011

输出样例#1: 复制

7

说明

7个反对称子串分别是:01(出现两次),10(出现两次),0101,1100和001011

题意:求异或意义下的回文串个数。

思路:正解是Manache算法变形先留坑,这里用哈希做,符合的串肯定是偶数长且前后对应的字符相反,那么把原串和反串都做一次哈希,然后枚举分界点二分最远的距离。

# include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn = 5e5+30;
char s[maxn], t[maxn];
LL base[maxn]={1}, p[maxn], q[maxn];
const LL mod = 1e9+7, seed = 233;
LL Hash(int pos, int len, int flag)
{
    if(!flag) return (p[pos] - p[pos-len] * base[len] % mod + mod)%mod;
    else return (q[pos] - q[pos+len] * base[len] % mod + mod)%mod;
}
int cal(int pos, int len)
{
    if(s[pos] == s[pos+1]) return 0;
    int l=1, r=len;
    while(l <= r)
    {
        int mid = l + r >> 1;
        if(Hash(pos, mid, 0) == Hash(pos+1, mid, 1)) l = mid + 1;
        else r = mid - 1;
    }
    return r;
}
int main()
{
    int n;
    LL ans = 0;
    scanf("%d",&n);
    for(int i=1; i<=n; ++i) base[i] = base[i-1] * seed % mod;
    scanf("%s",s+1);
    for(int i=1; i<=n; ++i)
    {
        t[i] = '1' - s[i] + '0';
        p[i] = (p[i-1] * seed % mod + s[i]) % mod;
    }
    for(int i=n; i; --i)
        q[i] = (q[i+1] * seed % mod + t[i]) % mod;
    for(int i=1; i<n; ++i)
        ans += cal(i, min(i,n-i));
    printf("%lld\n",ans);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值