H - Highways

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input
9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output
1 6
3 7
4 9
5 7
8 3


题意:给你这n个城镇的坐标,和其中一些城镇之间的高速公路,,让你再修建几条公路使得所有城镇都连通在一起。使得总路径最短,输出时输出两个城镇代表这两个城镇之间建造了一条公路,即输出你建造的公路。

分析:最短路的思路,只不过要优化,不然会超时。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#define N 1000100
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
#define ABS(a) a>=0?a:-a
using namespace std;
int father[1100],vis[1010][2];
struct node
{
    int a,b;
    double u;
} e[N];
struct coord
{
    double x,y;
} point[1010];
bool cmp(node q,node qq)
{
    return q.u<qq.u;
}
int _find(int x)
{
    if(x==father[x])
        return x;
    father[x]=_find(father[x]);
    return father[x];
}
void up_date(int n)
{
    for(int i=1; i<=n; i++)
        father[i]=i;
}
bool _check(int a,int b)//检测是否在一个集合内 1不在集合让其在一个集合内  and merge
{
    int root1,root2;
    root1=_find(a);
    root2=_find(b);
    if(root1==root2)
        return 0;
    father[root1]=root2;
    return 1;
}
double distant(double x1,double y1,double x2,double y2)
{
    x1=x1-x2;
    y1=y1-y2;
    return sqrt(x1*x1+y1*y1);
}
int main()
{
    int n,m,a,b,cnt=0,sign=0,flag=0;//sign表示自己修建公路的个数,flag表示最小生成树中已经有几条边了
    scanf("%d",&n);
    up_date(n);
    for(int i=1; i<=n; i++)
        scanf("%lf %lf",&point[i].x,&point[i].y);
    scanf("%d",&m);
    while(m--)
    {
        scanf("%d %d",&a,&b);
        if(_check(a,b))
            flag++;
    }
    for(int i=1; i<=n; i++)
        for(int j=i+1; j<=n; j++)
        {
            if(_find(i)==_find(j))//没有必要计算的边就不计算(在同一集合)
                continue;
            e[cnt].a=i;
            e[cnt].b=j;
            e[cnt++].u=distant(point[i].x,point[i].y,point[j].x,point[j].y);
        }
    sort(e,e+cnt,cmp);
    for(int i=0; i<cnt; i++)
    {
        if(_check(e[i].a,e[i].b))
        {
            vis[sign][0]=e[i].a;
            vis[sign++][1]=e[i].b;
            flag++;
        }
        if(flag+1==n)//提前退出
            break;
    }
    for(int i=0; i<sign; i++)
        printf("%d %d\n",vis[i][0],vis[i][1]);
}




转载于:https://www.cnblogs.com/dchnzlh/p/9780078.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
sklearn中自带了波士顿房价数据集,可以通过以下代码导入: ``` from sklearn.datasets import load_boston boston = load_boston() X = boston.data # 特征矩阵 y = boston.target # 目标向量 ``` 其中,X是一个13维的特征矩阵,y是一个样本数量为506的目标向量。可以通过以下代码查看数据集的描述: ``` print(boston.DESCR) ``` 输出结果如下: ``` .. _boston_dataset: Boston house prices dataset --------------------------- **Data Set Characteristics:** :Number of Instances: 506 :Number of Attributes: 13 numeric/categorical predictive. Median Value (attribute 14) is usually the target. :Attribute Information (in order): - CRIM per capita crime rate by town - ZN proportion of residential land zoned for lots over 25,000 sq.ft. - INDUS proportion of non-retail business acres per town - CHAS Charles River dummy variable (= 1 if tract bounds river; 0 otherwise) - NOX nitric oxides concentration (parts per 10 million) - RM average number of rooms per dwelling - AGE proportion of owner-occupied units built prior to 1940 - DIS weighted distances to five Boston employment centres - RAD index of accessibility to radial highways - TAX full-value property-tax rate per $10,000 - PTRATIO pupil-teacher ratio by town - B 1000(Bk - 0.63)^2 where Bk is the proportion of blacks by town - LSTAT % lower status of the population - MEDV Median value of owner-occupied homes in $1000's :Missing Attribute Values: None :Creator: Harrison, D. and Rubinfeld, D.L. This is a copy of UCI ML housing dataset. https://archive.ics.uci.edu/ml/machine-learning-databases/housing/ This dataset was taken from the StatLib library which is maintained at Carnegie Mellon University. The Boston house-price data of Harrison, D. and Rubinfeld, D.L. 'Hedonic prices and the demand for clean air', J. Environ. Economics & Management, vol.5, 81-102, 1978. Used in Belsley, Kuh & Welsch, 'Regression diagnostics ...', Wiley, 1980. N.B. Various transformations are used in the table on pages 244-261 of the latter. The Boston house-price data has been used in many machine learning papers that address regression problems. **References** - Belsley, Kuh & Welsch, 'Regression diagnostics: Identifying Influential Data and Sources of Collinearity', Wiley, 1980. 244-261. - Quinlan,R. (1993). Combining Instance-Based and Model-Based Learning. In Proceedings on the Tenth International Conference of Machine Learning, 236-243, University of Massachusetts, Amherst. Morgan Kaufmann.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值