Highways (最小生成树 Kruskal)

Highways

题目描述:
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题意:有n个城镇,以及m条现存的道路,给定每个城镇的坐标,需要修建一些道路使城镇之间相互连通并使花费最小(距离最小),输出需要修建的道路的端点城镇的编号。

题解:最小生成树问题,略有不同的是给出了一些边,这些边是不计入结果的,这里我使用Kruskal算法,需要自己构造图,然后存边,这个过程我是用两层for循环来实现的。把已经给出的边先加入到最小生成树中,然后在自己存的边中继续构造最小生成树,把需要加入的边两个端点输出即可。

AC代码:

#include <iostream>
#include <algorithm>
#include <math.h>
#include <cstdio>
#include <cmath>
#include <stdlib.h>
using namespace std;

int n,m,id,pre[755],cnt;  //id记录存入边的条数;
struct node    //记录每条边端点及权值;
{
    int from,to;
    double w;
} e[600000];
pair<int,int>a[755];    //记录每个城镇的坐标;
bool cmp(node a,node b)
{
    return a.w<b.w;
}
int Find(int x)
{
    if(x==pre[x])
        return x;
    else
        return pre[x]=Find(pre[x]);
}

void Kruskal()
{
    sort(e,e+id,cmp);
    for(int i=0;i<id;i++)
    {
        int u=e[i].from,v=e[i].to;
        double w=e[i].w;
        int fu=Find(u),fv=Find(v);
        if(fu==fv)
            continue;
        else
        {
            pre[fu]=fv;
            printf("%d %d\n",u,v);  //输出端点;
            cnt++;
        }
    }
}
int main()
{
    id=0;       
    cin>>n;
    for(int i=1;i<=n;i++)  //先对pre数组初始化;
        pre[i]=i;
    for(int i=1;i<=n;i++)   //输入坐标;
        cin>>a[i].first>>a[i].second;
    for(int i=1;i<=n;i++)    //构图、存边;
        for(int j=i+1;j<=n;j++)
    {
        double x1=a[i].first,y1=a[i].second;
        double x2=a[j].first,y2=a[j].second;
        double dis=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
        e[id++]={i,j,dis};
    }
    cin>>m;
    for(int i=1;i<=m;i++)   //输入已有道路并加入到最小生成树中;
    {                       //*****
      int a,b;
      cin>>a>>b;
      int fa=Find(a),fb=Find(b);
      if(fa==fb)
        continue;
      else
      {
          pre[fa]=fb;
          cnt++;    //只记录最小生成树的边数;
      }
    }
    Kruskal();
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值