HDU 2680 Choose the best route (最短路)

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7361    Accepted Submission(s): 2408


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

 

Sample Output
1 -1
 

 

Author
dandelion
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2112  1874  2544  1217  2066 
 
 
 
这道题目是有多个起点一个终点的最短路。
首先图的问题都要考虑是否存在重边的情况。
其次是这道题的做法,第一次我是循环w次dijkstra,每次更新最短距离,结果超时。
因为考虑是单源最短路算法,后来就找出一个点0,使它和其他起点是相同且时间为0。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int MAXN=1000+5;
const int INF=0x3f3f3f3f;
int d[MAXN],w[MAXN][MAXN],vis[MAXN];
int n,m,s,en,num,in;
void dijkstra(int start)
{
    memset(vis,0,sizeof(vis));
    for(int i=0;i<=n;i++)
        d[i]=INF;
    d[start]=0;
    for(int i=0;i<=n;i++)
    {
        int temp=INF,x;
        for(int j=0;j<=n;j++)
        {
            if(!vis[j] && d[j]<temp)
            {
                x=j;
                temp=d[j];
            }
        }
        vis[x]=1;
        for(int j=0;j<=n;j++)
            if(d[x]+w[x][j]<d[j])
                d[j]=d[x]+w[x][j];
    }
}
int main()
{
    while(scanf("%d %d %d",&n,&m,&s)!=EOF)
    {
        for(int i=0;i<=n;i++) //这里要注意,加入超级源点之后,这个点也要放到图中去
            for(int j=0;j<=n;j++)
            {
                if(i==j) w[i][j]=0;
                else w[i][j]=INF;
            }


        for(int i=1;i<=m;i++)
        {
            int star,en,val;
            scanf("%d %d %d",&star,&en,&val);
            if(val<w[star][en]) //防止重边,如果出现重边的情况,选时间最短的边
                w[star][en]=val; 
        }

        scanf("%d",&num);
        for(int i=1;i<=num;i++)
        {
            scanf("%d",&in);
            w[0][in]=0; //加入一个超级源点
        }

        dijkstra(0);

        if(d[s]==INF)
            printf("-1\n");
        else
            printf("%d\n",d[s]);
    }
    return 0;
}
View Code

 还有一种思路是利用反向图,这样利用一次dijkstra再找出最小值就行了。

 

转载于:https://www.cnblogs.com/clliff/p/4034920.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值