hdu 2680 Choose the best route(最短路)

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12465    Accepted Submission(s): 4057


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
题意:n个城市,m条路,终点是s,再输入m条路,还有a个起点,问从其中一个起点开始到终点最短路是多少

思路:如果枚举起点肯定会TLE,我们可以反向构图,从终点到所有点求最短路即可

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 1010
#define M 20010
#define INF 100000000
int n,m;
int ma[N][N];
int vis[N],d[N];
void init()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        ma[i][j]=INF;
}
void djstl(int s)
{
    for(int i=1;i<=n;i++)
    {
        d[i]= i==s?0:ma[s][i];
        vis[i]=(i==s);
    }
    for(int i=1;i<n;i++)
    {
        int maxn=INF;int v=-1;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&maxn>d[j])
            {
                maxn=d[j];
                v=j;
            }
        if(v==-1) continue;
        vis[v]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&d[v]+ma[v][j]<d[j])
                d[j]=d[v]+ma[v][j];
        }
    }
}
int main()
{
    int s,e,t;
    int p,q,w;
   while(~scanf("%d %d %d",&n,&m,&s))
   {
       init();
       for(int i=0;i<m;i++)
       {
           scanf("%d %d %d",&p,&q,&w);
           ma[q][p]=min(ma[q][p],w);
       }
       djstl(s);
       scanf("%d",&t);
       int maxn=INF;
       for(int i=0;i<t;i++)
       {
           scanf("%d",&e);
           maxn=min(maxn,d[e]);
       }
       if(maxn==INF)
        printf("-1\n");
       else
        printf("%d\n",maxn);
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值