POJ 3254 Corn Fields(状态压缩dp)

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题目大意:给个地图,0的地方不能放牛,1的地方可以放牛,两个牛不能相邻放,经典状压dp,用01串表示放与不放,然后用位运算判断满不满足条件,这个可以用方格取数的想法来写,只不过那个是每次比较大小,这个都不用比较直接传递下来就可以了,最后加起来,具体看代码

题目链接:点击打开链接


代码注释:


#include<iostream>
#include<cstring>
using namespace std;
int q[200],dp[105][200],map[105][15],n,mm,ans,flag;
void solve()
{
    int m=0;
    for(int i=0; i<(1<<mm); i++)
        if((i&(i<<1))==0)//相邻不放的情况存起来
            q[m++]=i;
    memset(dp,0,sizeof(dp));
    ans=0;
    for(int j=0; j<m; j++)//列举所有情况
    {
        flag=1;
        for(int k=0; k<mm; k++ )//每个情况依次对比
        {
            if(q[j]&(1<<k))
                if(map[1][k]==0)//如果该放牛的地方没有放,这种情况不满足跳过
                    flag=0;
        }
        if(flag)
            dp[1][j]=1;//标记为1表示这种状态可行
    }
    for(int i=2; i<=n; i++)
        for(int j=0; j<m; j++)//上面先求出dp[1][],下面过程基本和上面一样
        {
            flag=0;
            for(int k=0; k<mm; k++)
            {
                if(q[j]&(1<<k))
                {
                    if(map[i][k]==0)
                        flag=1;
                }
            }
            if(flag)
                continue;
            for(int k=0; k<m; k++)
                if((q[j]&q[k])==0)//上下行不相邻
                    dp[i][j]+=dp[i-1][k];//向下传递满足的情况
        }
    for(int i=0; i<m; i++)
    {
        ans+=dp[n][i];//加上所有满足的情况
        ans%=100000000;
    }
    cout<<ans<<endl;
}
int main()
{
    while(cin>>n>>mm)
    {
        for(int i=1; i<=n; i++)
            for(int j=0; j<mm; j++)
                cin>>map[i][j];
        solve();
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值