HDU -> acm -> Strange fuction

Strange fuction

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 31   Accepted Submission(s) : 28
Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
 
 
2
100
200
 

Sample Output
 
 
-74.4291
-178.8534
 

#include<stdio.h>  
#include<math.h>  
  
double df(double x)  
{  
    return 42*pow(x,6)+48*pow(x,5)+21*x*x+10*x;  
}  
  
double f(double x,double y)  
{  
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-y*x;  
}  
  
int main()  
{  
    int t,i;  
    double y,left,right,mid;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%lf",&y);  
        left=0,right=100;  
        for(i=1;i<=100;i++)  
        {  
            mid=(left+right)/2;  
            if(df(mid)>y)  
                right=mid;  
            else  
                left=mid;  
        }  
        printf("%.4lf\n",f(mid,y));  
    }  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值