hdu -> acm -> A Multiplication Game

A Multiplication Game

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 &lt; n &lt; 4294967295 and the winner is who first reaches p &gt;= n.<br>
 

Input
Each line of input contains one integer number n.<br>
 

Output
For each line of input output one line either <br><br>Stan wins. <br><br>or <br><br>Ollie wins.<br><br>assuming that both of them play perfectly.<br>
 

Sample Input
 
 
162
17
34012226
 

Sample Output
 
 
Stan wins.
Ollie wins.
Stan wins.
 

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

__int64 p,n,count1;
int main()
{
    while(scanf("%I64d",&n)!=EOF)
    {
        count1=0;
        p=1;
        while(true)
        {
            if(p>=n)break;
            count1++;
            if(count1&1)p*=9;
            else p*=2;
        }
        printf("%s\n",count1&1?"Stan wins.":"Ollie wins.");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值