A Multiplication Game HDU - 1517

A Multiplication Game
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6584 Accepted Submission(s): 3746

Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input
Each line of input contains one integer number n.

Output
For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

Source
University of Waterloo Local Contest 2001.09.22

就是找规律,手写一下,打个表就行。。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>

#define ll  long long
#define ull unsigned long long

using namespace std;

ll maxn = 4294967295;

ll s[30];
bool  sg[30];

int main()
{
        ll  n = 9;
    memset(sg, 0, sizeof(sg));
        s[0] = 9;
        for(int i = 1; i < 28; i++)
        {
        if(!sg[i-1]) {
            n *= 2;
            s[i] = n;
            sg[i] = true;   
        } else {
            n *= 9;
            s[i] = n;
            } 
    }
    for(int i = 0; i < 28; i++) cout << i << " "  << sg[i] << " "<<  s[i] << endl;
        while(scanf("%lld",&n) != EOF) {
         for(int i = 0; i < 28; i++) {
        if(n > s[i]) continue;
        else {
            if(!sg[i]) puts("Stan wins.");
            else puts("Ollie wins.");
            break;
        }
         }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值