(Android)为什么我们不需要导入android support v4包?

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/devnn/article/details/83104264

开发中发现了一个奇怪的问题,在没有引入support v4包的情况下,却可以用support v4路径下的Fragment。于是看了一下Android Studio左侧的External Libaries依赖树,发现已经包含了support v4的包,而且其中还有很多自己没有添加过的包。看了一下gradle文件配置的依赖项,只加了constraint-layout和appcompat-v7的包,于是猜测可能appcompat-v7中已经包含了support v4,删掉appcompat-v7的依赖,刷新一下,果然External Libaries依赖树中去掉了一大堆依赖包,其中support v4也没有了。把appcomat-v7添加回去,那些不见的依赖包又有了。appcompat-v7真是很强大。

展开阅读全文

没有更多推荐了,返回首页