POJ2234:Matches Game(Nim博弈)

Matches Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12325 Accepted: 7184

题目链接:http://poj.org/problem?id=2234

Description:

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input:

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output:

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input:

2 45 45
3 3 6 9

Sample Output:

No
Yes

题意:

给出n堆石子,每一堆有相应的个数,然后问是否先手必胜。

 

题解:

Nim博弈模板题。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 25;
int n;
int a[N];
int main(){
    while(scanf("%d",&n)!=EOF){
        int x = 0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            x^=a[i];
        }
        int f = 0;
        for(int i=1;i<=n;i++){
            if((a[i]^x)<a[i]) f=1;
        }
        if(f) cout<<"Yes"<< '\n';
        else cout<<"No"<<'\n';
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/heyuhhh/p/10574688.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值