POJ 2234

Matches Game
   

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes
#include<stdio.h>
#include<stdlib.h>
int main(int argc, char const *argv[])
{
	int M;
	int i;
	int a,b;
	while(~scanf("%d",&M))
	{    
         a=0;
		for(i=0;i<M;i++)
			{
				scanf("%d",&b);
				a^=b;
			}
			printf("%s\n",a?"Yes":"No");
	}
	return 0;
}
这道题主要就是博弈的问题,火柴堆得开始数量就决定了输赢(每一步都走的最好的一步),任何一个整数都可以分解为二进制数,这样就可以把一堆火柴分解为若干个
二进制位的子堆,如果每一种大小的子堆数目都是偶数则这是个平衡的游戏,否则是非平衡的。游戏人I在非平衡的游戏中可以获胜,游戏人II可以在平衡的游戏中获胜。


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值