hdu3887 Counting Offspring(dfs序+树状数组)

Counting Offspring

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2635    Accepted Submission(s): 907


Problem Description
You are given a tree, it’s root is p, and the node is numbered from 1 to n. Now define f(i) as the number of nodes whose number is less than i in all the succeeding nodes of node i. Now we need to calculate f(i) for any possible i.
 

Input
Multiple cases (no more than 10), for each case:
The first line contains two integers n (0<n<=10^5) and p, representing this tree has n nodes, its root is p.
Following n-1 lines, each line has two integers, representing an edge in this tree.
The input terminates with two zeros.
 

Output
For each test case, output n integer in one line representing f(1), f(2) … f(n), separated by a space.
 

Sample Input
  
  
15 7 7 10 7 1 7 9 7 3 7 4 10 14 14 2 14 13 9 11 9 6 6 5 6 8 3 15 3 12 0 0
 

Sample Output
  
  
0 0 0 0 0 1 6 0 3 1 0 0 0 2 0
 

Author
bnugong
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3450  1166  3030  1541  3743


 题解:统计树的每个节点下面的比它小的点的个数,首先利用dfs序找到每个点的子节点的区间,然后从小到大的查询就好了,每次查询完再把这个点插入进去;
#include<bits/stdc++.h>
#define MAXN 100005
using namespace std;
int info[MAXN],lit[MAXN],l[MAXN],r[MAXN],tree[MAXN*2],vis[MAXN];
vector<int> to,nxt;
int cnt,n,p;
void add(int a,int b)
{
    to.push_back(b);
    nxt.push_back(info[a]);
    info[a]=to.size()-1;
}
void init()
{
    memset(info,-1,sizeof(info));
    memset(lit,0,sizeof(lit));
    to.clear();
    nxt.clear();
    memset(tree,0,sizeof(tree));
    memset(vis,0,sizeof(vis));
    cnt=1;
}
void dfs(int x)
{
	if(!vis[x])
	{
		vis[x]=1;
		l[x]=cnt++;
	}
    for(int i=info[x];i!=-1;i=nxt[i])
    {
    	if(!vis[to[i]])
    	dfs(to[i]);
	}
	r[x]=cnt++;
}
inline lowbit(int x)
{
    return x&(-x);
}
void mod(int x)
{
    for(int i=x;i<cnt;i+=lowbit(i))
        tree[i]+=1;
}
int sum(int x)
{
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
        ans+=tree[i];
    return ans;
}
int main()
{
    while(scanf("%d%d",&n,&p)!=EOF)
    {
    	if(n==0&&p==0)
    	break;
    	init();
        for(int i=0;i<n-1;i++)
        {
            int u,v;
        	scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
    	}
    	dfs(p);
    	for(int i=1;i<=n;i++)
    	{
        	lit[i]=sum(r[i]-1)-sum(l[i]);
   	    	mod(l[i]);
    	}
    	for(int i=1;i<=n;i++)
    	{
    		if(i==n)
    		printf("%d\n",lit[i]);
    		else
    		printf("%d ",lit[i]);
		}  
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值