多校7.21A——维护技巧——OO’s Sequence

Problem Description
OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy a i mod a j=0,now OO want to know
i=1nj=inf(i,j) mod 109+7.
 

 

Input
There are multiple test cases. Please process till EOF.
In each test case: 
First line: an integer n(n<=10^5) indicating the size of array
Second line:contain n numbers a i(0<a i<=10000)
 

 

Output
For each tests: ouput a line contain a number ans.
 

 

Sample Input
5 1 2 3 4 5
 

 

Sample Output
23
 

 

Source
 

 

Recommend
We have carefully selected several similar problems for you:   5299  5298  5297  5296  5295 
/*
 题意:对于所有的子区间找a[i]在这个区间没有因子的所有的情况
 对于一个数a[i]它的价值是L[i]:从左往右最接近的因子的下标,R[[i]:从右往左最接近的因子下标,a[i]在这个区间内都是可以的那么总共的种类区间有(i - L[i]) * (R[i] - i)
总复杂度O(n根号n)
用index数组来记录该因子出现的位置
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int MAX = 100000 + 10;
const int mod = 1e9 + 7;
int a[MAX];
int L[MAX], R[MAX], index[MAX];

int main()
{
    int n;
    while(~scanf("%d", &n)){
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        memset(index, -1, sizeof(index));
        for(int i = 1; i <= n; i++){
            int temp = sqrt(1.0 * a[i]);
            int l = 0;
            for(int j = 1; j <= temp; j++){
                if(a[i] % j == 0){
                    if(index[j] != -1) 
                        l = max(index[j], l);
                    if(index[a[i] / j] != -1)
                        l = max(index[a[i] / j], l);
                }
            }
                index[a[i]] = i;
                L[i] = l;
        }
        memset(index, -1, sizeof(index));
            for(int i = n; i >= 1 ;i--){
                int temp = sqrt(1.0 * a[i]);
                int r = n + 1;
                for(int j = 1; j <= temp; j++){
                    if(a[i] % j == 0){
                        if(index[j] != -1)
                            r = min(index[j], r);
                        if(index[a[i] / j] != -1)
                            r = min(index[a[i] / j], r);
                    }
                }
                index[a[i]] = i;
                R[i] = r;
            }
         int l1, r1;
         int  sum = 0;
        for(int i = 1; i <= n; i++){
            l1 = i - L[i], r1 = R[i] - i ;
            sum = (l1 * r1 % mod + sum) % mod;
        }
        printf("%d\n", sum);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/zero-begin/p/4665441.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于PyTorch的Embedding和LSTM的自动写诗实验LSTM (Long Short-Term Memory) 是一种特殊的循环神经网络(RNN)架构,用于处理具有长期依赖关系的序列数据。传统的RNN在处理长序列时往往会遇到梯度消失或梯度爆炸的问题,导致无法有效地捕捉长期依赖。LSTM通过引入门控机制(Gating Mechanism)和记忆单元(Memory Cell)来克服这些问题。 以下是LSTM的基本结构和主要组件: 记忆单元(Memory Cell):记忆单元是LSTM的核心,用于存储长期信息。它像一个传送带一样,在整个链上运行,只有一些小的线性交互。信息很容易地在其上保持不变。 输入门(Input Gate):输入门决定了哪些新的信息会被加入到记忆单元中。它由当前时刻的输入和上一时刻的隐藏状态共同决定。 遗忘门(Forget Gate):遗忘门决定了哪些信息会从记忆单元中被丢弃或遗忘。它也由当前时刻的输入和上一时刻的隐藏状态共同决定。 输出门(Output Gate):输出门决定了哪些信息会从记忆单元中输出到当前时刻的隐藏状态中。同样地,它也由当前时刻的输入和上一时刻的隐藏状态共同决定。 LSTM的计算过程可以大致描述为: 通过遗忘门决定从记忆单元中丢弃哪些信息。 通过输入门决定哪些新的信息会被加入到记忆单元中。 更新记忆单元的状态。 通过输出门决定哪些信息会从记忆单元中输出到当前时刻的隐藏状态中。 由于LSTM能够有效地处理长期依赖关系,它在许多序列建模任务中都取得了很好的效果,如语音识别、文本生成、机器翻译、时序预测等。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值