7.21多校——5289RMQ_st + 二分搜索 + 单调队列——Assignment

roblem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

 

Output
For each test,output the number of groups.
 

 

Sample Input
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

 

Sample Output
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

 

Author
FZUACM
 

 

Source
 

 

Recommend
We have carefully selected several similar problems for you:   5299  5298  5297  5296  5295 
/*
题意:

RMQ_st算法
复杂度:预处理nlogn 查询O(1)
实现:
用DP的思想
mx[i][j] 定义为以i为起点长度为1<<j的区间内的最大值
状态转移方程 mx[i][j] = mx[i][j-1] + mx[i+(1<<(j-1))][j-1] 
把区间分成长度为1<<(j-1)的两个部分
总共处理的长度从1到log2(n),起点从1到n
所以总复杂度O(nlogn)

二分搜索位置
假定了l到r之间必定有一段
二分搜索从i到n,得到以该点开始能到右边最多多少
如果i到mid可以说明二分区域在另一块,另l = mid
因为有RMQ的存在能得到该区间是否满足,二分对于数列需单调的要求就是因为要使得端点为极值

*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int MAX = 100000 + 10;
int mx[MAX][20], mn[MAX][20];
int a[MAX]; 
int n;
void  rmq()
{
    for(int i = 1; i <= n; i++)
        mx[i][0] = mn[i][0] = a[i];
        int m = log2(n*1.0);
        for(int i = 1; i <= m; i++){
            for(int j = 1;j <= n; j++){
                if(j + (1 << (i - 1)) <= n)
                    mx[j][i] = max(mx[j][i-1], mx[j + (1 << (i - 1))][i - 1]);
                    mn[j][i] = min(mn[j][i-1], mn[j + (1 << (i - 1))][i - 1]);
                }
            }
}

int rmqmin(int l, int r)
{
    int m = log2(1.0*(r - l + 1));
    return min(mn[l][m], mn[r - (1 << m) + 1][m]);
}

int rmqmax(int l, int r)
{
    int m = log2(1.0*(r - l + 1));
    return max(mx[l][m], mx[r - (1 << m) + 1][m]);
}

int cal(int l, int r)
{
    return rmqmax(l, r) - rmqmin(l, r);
}

int main()
{
    int T, k;
    scanf("%d", &T);
    while(T--){
        long long  ans = 0;
        scanf("%d%d", &n, &k);
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        rmq();
       // printf("%d %d\n",rmqmax(2, 2),rmqmin(1,5));
        int l, r, mid;
        for(int i = 1; i <= n; i++){
            l = i, r = n;
            while(l + 1 < r){
                 mid = (l + r) >> 1;
                if(cal(i, mid) < k)
                    l = mid;
                else r = mid;
            }
            if(cal(i, r) < k)
                ans = ans + (long long )(r - i + 1);
            else{
               ans = ans + (long long )(l - i + 1);
            }
        }
       printf("%lld\n", ans);
    }
    return 0;
}

            
        
/*
单调队列(双端队列做法)
deque    
deque q
主要用的库函数 
q.pop_back():删去最后的值
q.push_back():把当前数入队到最后
q.pop_front():删去最前面的值
q.front():得到最前面的值
q.back():得到最后面的值
单调队列维护最小最大值在队列里面保存的是下标,不过也可以开结构体把两个都保存下来
假设我们现在维护最大值:
假定j为队列最后值的下标,i为当前需要入队的下标(下标指的是原数组中所在的位置)
if(a[j] < a[i]) 那么最大值是j-1前面的数或者当前这个i,直接q.back()删去当前的a[j]
直到能插入,处理结束后最前面的的值q.front为1到i里面最大的值的下标

对于每一个数我们找最往左的位置,不断更新下标
每一个数入队出队次数就一次
所以复杂度为O(c*n) = O(n)
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

const int MAX = 1e5 + 10;
struct edge{
    int n, id;
};
deque<edge> Q1, Q2;
int a[MAX];

int main()
{
    int T;
    int n, k;
    scanf("%d", &T);
    while(T--){
            Q1.clear();
            Q2.clear();
        long long ans = 0;
        scanf("%d%d", &n, &k);
        for(int i = 1; i <= n ;i++)
            scanf("%d", &a[i]);
        int head = 1;
        for(int i = 1; i <= n ; i++){
            edge now = (edge){a[i], i};
            while(!Q1.empty()){
                edge temp = Q1.back();
                if(now.n > temp.n) Q1.pop_back();//得到max
                else break;
            }
            Q1.push_back(now);

            while(!Q2.empty()){
                edge temp = Q2.back();
                if(now.n < temp.n) Q2.pop_back();//得到min
                else break;
            }
            Q2.push_back(now);
           if(i == 1) ans++;
           else {
               while(1){
                   edge big = Q1.front();
                   edge small = Q2.front();
                   if(big.n - small.n < k) break;
                   else {
                       if(small.id < big.id){
                            head = small.id + 1;
                            Q2.pop_front();
                       }
                       else {
                           head = big.id + 1;
                           Q1.pop_front();
                       }
                   }
               }
           ans += i - head + 1;
           }
       }
        printf("%lld\n", ans);
    }
    return 0;
}
          

  

转载于:https://www.cnblogs.com/zero-begin/p/4667671.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C语言是一种广泛使用的编程语言,它具有高效、灵活、可移植性强等特点,被广泛应用于操作系统、嵌入式系统、数据库、编译器等领域的开发。C语言的基本语法包括变量、数据类型、运算符、控制结构(如if语句、循环语句等)、函数、指针等。在编写C程序时,需要注意变量的声明和定义、指针的使用、内存的分配与释放等问题。C语言中常用的数据结构包括: 1. 数组:一种存储同类型数据的结构,可以进行索引访问和修改。 2. 链表:一种存储不同类型数据的结构,每个节点包含数据和指向下一个节点的指针。 3. 栈:一种后进先出(LIFO)的数据结构,可以通过压入(push)和弹出(pop)操作进行数据的存储和取出。 4. 队列:一种先进先出(FIFO)的数据结构,可以通过入队(enqueue)和出队(dequeue)操作进行数据的存储和取出。 5. 树:一种存储具有父子关系的数据结构,可以通过中序遍历、前序遍历和后序遍历等方式进行数据的访问和修改。 6. 图:一种存储具有节点和边关系的数据结构,可以通过广度优先搜索、深度优先搜索等方式进行数据的访问和修改。 这些数据结构在C语言中都有相应的实现方式,可以应用于各种不同的场景。C语言中的各种数据结构都有其优缺点,下面列举一些常见的数据结构的优缺点: 数组: 优点:访问和修改元素的速度非常快,适用于需要频繁读取和修改数据的场合。 缺点:数组的长度是固定的,不适合存储大小不固定的动态数据,另外数组在内存中是连续分配的,当数组较大时可能会导致内存碎片化。 链表: 优点:可以方便地插入和删除元素,适用于需要频繁插入和删除数据的场合。 缺点:访问和修改元素的速度相对较慢,因为需要遍历链表找到指定的节点。 栈: 优点:后进先出(LIFO)的特性使得栈在处理递归和括号匹配等问题时非常方便。 缺点:栈的空间有限,当数据量较大时可能会导致栈溢出。 队列: 优点:先进先出(FIFO)的特性使得
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值