7.28多校1004——模拟——Painter

Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 

 

Output
Output an integer as described in the problem description.
 

 

Sample Input
2 4 RR.B .RG. .BRR B..R 4 RRBB RGGB BGGR BBRR
 

 

Sample Output
3 6
 

 

Source
 

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5326  5325  5324  5323  5322 
/*
大意:R只能右下涂,B只能右上涂,G表示被两种颜色都涂了,问你至少涂多少次把它涂成这样,暴力枚举每种斜线从一个边界到另一个边界
做了半天最后被场外队友A了。
有好多要学习的地方
!!!看题仔细!!!
1.能简单开for循环的不要开while
2.ok判断能省很多代码量
3.想清楚dfs用来干什么~~不要乱开变得繁琐
4注意重复点不要多次进行DFS
*/
#include <cstdio>
#include <cstring>
#include <algorithm>

char map[55][55];
int f_left, f_right;
int cnt, n ,m;

bool ok(int x, int y)
{
    if(x < 0 || x >= n || y < 0 || y >= m)
        return false;
    return true;
}

void left(int x, int y)
{
    if(ok(x, y)){
        if(map[x][y] == 'R' || map[x][y] == 'G'){
            if(f_left == 0){
                cnt++;
                f_left = 1;
            }
        }
        else f_left = 0;
    left(x + 1, y + 1);
    }
    return;
}

void right(int x, int y)
{
    if(ok(x, y)){
        if(map[x][y] == 'B' || map[x][y] == 'G'){
            if(f_right == 0){
                cnt++;
                f_right = 1;
            }
        }
        else f_right = 0;
        right(x + 1, y - 1);
    }
    return ;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--){
        memset(map, 0, sizeof(map));
        cnt = 0;
        scanf("%d", &n);
        for(int i = 0 ; i < n; i++){
            scanf("%s", map[i]);
            m = strlen(map[i]);
        }
        for(int i = 0; i < n ; i++){
            f_left = 0;
            left(i, 0);
        }
        for(int i = 1; i < m ; i++){
            f_left = 0;
            left(0, i);
        }
        for(int i = 0; i < n; i++){
            f_right = 0;
            right(i,m-1);
        }
        for(int i = 0; i < m - 1 ; i++){
            f_right = 0;
            right(0, i);
        }
        printf("%d\n", cnt);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/zero-begin/p/4684249.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值