Description
判断一个图是否为一个边通图
Input
n 顶点 (n<=100)
边
Output
1 表示连通
0 表示不边通
Sample Input
5
1 2
2 3
5 4
0 0
Sample Output
0
分析
我认为最简单的方法就是这个。代码量少,容易理解。存完邻接矩阵后把所有节点遍历一遍(所有路走一遍),所有节点都通就OK。
上代码
#include<iostream>
#include<cstdio>
using namespace std;
int a[101][101],b[101],x,y,n,ans;
int dfs(int k)
{
for(int i=1;i<=n;i++)//遍历所有节点
{
if(a[i][k]==1&&b[i]==0)
{
b[i]=1;//记录
ans++;//又一个节点OK,ans++;
dfs(i);
}
}
}
int main()
{
cin>>n;
cin>>x>>y;
while(x!=0&&y!=0)
{
a[x][y]=1;
a[y][x]=1;
cin>>x>>y;
}
dfs(1);
if(ans==n)//看是不是连通
{
cout<<1;
}
else cout<<0;
return 0;
}