hdu1576 逆元板子题

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6867    Accepted Submission(s): 5457

Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
 

 

Sample Input
2
1000 53
87 123456789
 
Sample Output
7922 6060
 
Author
xhd
 
Source

 

问题链接HDU1576 A/B

--------------------- 本文来自 海岛Blog 的CSDN 博客 ,全文地址请点击:https://blog.csdn.net/tigerisland45/article/details/51239640?utm_source=copy 

 

思路  

设(A/B)%9973 = K, 则A/B = k + 9973x  (x未知), 因此A = kB + 9973xB,

又A%9973 = n, 所以kB%9973 = n,  故kB = n + 9973y (y未知)

故(k/n)B +(-y/n)*9973 = gcd(B,9973) = 1

扩展欧几里得 求出k/n,  再乘以个n,取模,就是答案了

代码

#include <cstdio>
#include <cstdlib>
#include <ctime> 
#define m 9973
 
void extend_gcd(int a,int b,int& d,int& x,int& y)
{
    if(!b){ d = a; x = 1; y = 0;}
    else{ extend_gcd(b,a%b,d,y,x); y -= x*(a/b);}
}
 
int main()
{
    int t,n,b,a,d,x,y;
   scanf("%d",&t);while(t--){
        scanf("%d%d",&n,&b);
        extend_gcd(b,m,d,x,y);
        x=(x%m+m)%m;
        printf("%d\n",(x*n)%m);
   }//printf("time used=%.2f\n",(double)clock() / CLOCKS_PER_SEC);
   return 0;
}

 

其中还看到有人直接枚举的 代码如下

#include<cstdio>
#include<ctime>

int main(){
    long long n,b;int t;scanf("%d",&t);//不用long long就WA
    while(t--){
        scanf("%lld%lld",&n,&b);
        for(int i = 0; i < 9973; i++)
        {
            if((i*b -n)%9973 == 0){
                printf("%d\n",i);
                break;
            }
        }
    }

    //printf("time used=%.2f\n",(double)clock() / CLOCKS_PER_SEC);

    return 0;
}

 

转载于:https://www.cnblogs.com/163467wyj/p/9758073.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值