BZOJ 4395: [Usaco2015 dec]Switching on the Lights

4395: [Usaco2015 dec]Switching on the Lights

Description

Farmer John has recently built an enormous barn consisting of an N×NN×N grid of rooms (2≤N≤100), numbered from (1,1)up to (N,N). Being somewhat afraid of the dark, Bessie the cow wants to turn on the lights in as many rooms as possible.

Bessie starts in room (1,1), the only room that is initially lit. In some rooms, she will find light switches that she can use to toggle the lights in other rooms; for example there might be a switch in room (1,1) that toggles the lights in room (1,2)(1,2). Bessie can only travel through lit rooms, and she can only move from a room (x,y)(x,y) to its four adjacent neighbors (x−1,y), (x+1,y), (x,y−1)(x,y−1) and (x,y+1) (or possibly fewer neighbors if this room is on the boundary of the grid).

Please determine the maximum number of rooms Bessie can illuminate.

有N*N个房间,组成了一张N*N的网格图,Bessie一开始位于左上角(1,1),并且只能上下左右行走。

一开始,只有(1,1)这个房间的灯是亮着的,Bessie只能在亮着灯的房间里活动。

有另外M条信息,每条信息包含四个数a,b,c,d,表示房间(a,b)里有房间(c,d)的灯的开关。

请计算出最多有多少个房间的灯可以被打开

Input

The first line of input contains integers NN and MM (1≤M≤20,000).

The next MM lines each describe a single light switch with four integers xx, yy, aa, bb, that a switch in room (x,y) can be used to toggle the lights in room (a,b). Multiple switches may exist in any room, and multiple switches may toggle the lights of any room.

Output

A single line giving the maximum number of rooms Bessie can illuminate.

Sample Input

3 6
1 1 1 2
2 1 2 2
1 1 1 3
2 3 3 1
1 3 1 2
1 3 2 1

Sample Output

5

思路:

  对于这道题,我是瞎搞的,每次BFS处理当前能到达的房间并且开灯(用挂链的形式开灯)强制BFS1000次(每次q,empty()了就把(1,1)压进去再BFS)。就AC啦

话说这种方法我总用呢,手动滑稽

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <iostream>
using namespace std;
int map[111][111];
bool vis[111][111];
int head[111*111],to[21000],next[21000],cnt;
int movx[4]={1,-1,0,0};
int movy[4]={0,0,1,-1};
struct node {
    int x,y;
};
void add_edge(int a,int b) {
    to[++cnt]=b;
    next[cnt]=head[a];
    head[a]=cnt;
}
queue<node>q;
int n;
int main() {
    int m;
    map[1][1]=1;
    scanf("%d%d",&n,&m);
    while(m--) {
        int a,b,c,d;
        scanf("%d%d%d%d",&a,&b,&c,&d);
        add_edge((a-1)*n+b,(c-1)*n+d);
    }
    
    int tt=1000;
    while(tt--) {
        memset(vis,0,sizeof vis);
        q.push((node){1,1});
        vis[1][1]=0;
        while(!q.empty()) {
            node u=q.front();
            q.pop();
            int xx=u.x,yy=u.y;
            for(int i=head[(xx-1)*n+yy];i;i=next[i]) {
                int po=to[i];
                int h,l;
                if(!po%n) {
                    h=po/n;
                    l=n;
                }
                else {
                    h=po/n+1;
                    l=po-(h-1)*n;
                }
                if(l==0)h--,l=n;
                map[h][l]=1;
            }
            for(int i=0;i<4;i++) {
                int tx=xx+movx[i],ty=yy+movy[i];
                if(map[tx][ty]&!vis[tx][ty]) {
                    q.push((node){tx,ty});
                    vis[tx][ty]=1;
                }
            }
        }
    }
    int ans=0;
    for(int i=1;i<=n;i++) {
        for(int j=1;j<=n;j++) {
            if(map[i][j])ans++;
        }
    }
    printf("%d\n",ans);
}

 

转载于:https://www.cnblogs.com/Tobichi/p/9107813.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值