【bzoj 4395】 Switching on the Lights 【Usaco2015 dec】

4 篇文章 0 订阅

Description

Farmer John has recently built an enormous barn consisting of an N×NN×N grid of rooms (2≤N≤100), numbered from (1,1)up to (N,N). Being somewhat afraid of the dark, Bessie the cow wants to turn on the lights in as many rooms as possible.

Bessie starts in room (1,1), the only room that is initially lit. In some rooms, she will find light switches that she can use to toggle the lights in other rooms; for example there might be a switch in room (1,1) that toggles the lights in room (1,2)(1,2). Bessie can only travel through lit rooms, and she can only move from a room (x,y)(x,y) to its four adjacent neighbors (x−1,y), (x+1,y), (x,y−1)(x,y−1) and (x,y+1) (or possibly fewer neighbors if this room is on the boundary of the grid).

Please determine the maximum number of rooms Bessie can illuminate.

 

有N*N个房间,组成了一张N*N的网格图,Bessie一开始位于左上角(1,1),并且只能上下左右行走。

一开始,只有(1,1)这个房间的灯是亮着的,Bessie只能在亮着灯的房间里活动。

有另外M条信息,每条信息包含四个数a,b,c,d,表示房间(a,b)里有房间(c,d)的灯的开关。

请计算出最多有多少个房间的灯可以被打开

 

Input

The first line of input contains integers NN and MM (1≤M≤20,000).

The next MM lines each describe a single light switch with four integers xx, yy, aa, bb, that a switch in room (x,y) can be used to toggle the lights in room (a,b). Multiple switches may exist in any room, and multiple switches may toggle the lights of any room.

Output

A single line giving the maximum number of rooms Bessie can illuminate.

Sample Input

3 6
1 1 1 2
2 1 2 2
1 1 1 3
2 3 3 1
1 3 1 2
1 3 2 1

Sample Output

5

HINT

 

Here, Bessie can use the switch in (1,1) to turn on lights in (1,2) and (1,3). She can then walk to (1,3) and turn on the lights in (2,1), from which she can turn on the lights in (2,2). The switch in (2,3) is inaccessible to her, being in an unlit room. She can therefore illuminate at most 5 rooms.

 

Source

Silver鸣谢Claris提供译文

这道题直接BFS暴力枚举到答案不再增大即可,下面是程序:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int N=105,g[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
struct node{
	int x,y;
};
struct edge{
	int x,y,next;
}e[20005];
struct queue{
	node a[N*N];
	int l,r;
	void clear(){
		l=0,r=1;
	}
	bool empty(){
		return l+1==r;
	}
	void push(node x){
		a[r]=x;
		r=(r+1)%N;
	}
	void pop(){
		l=(l+1)%N;
	}
	node front(){
		return a[(l+1)%N];
	}
}q;
int n,head[N][N],k,ans=1,last;
bool can[N][N],vis[N][N];
inline void add(int a,int b,int c,int d){
	e[++k]=(edge){c,d,head[a][b]};
	head[a][b]=k;
}
void BFS(){
	int i,x,y,a,b;
	q.clear();
	memset(vis,0,sizeof(vis));
	vis[1][1]=1;
	q.push((node){1,1});
	while(!q.empty()){
		x=q.front().x,y=q.front().y;
		q.pop();
		for(i=head[x][y];i;i=e[i].next){
			if(!can[e[i].x][e[i].y]){
				can[e[i].x][e[i].y]=1;
				ans++;
			}
		}
		for(i=0;i<4;i++){
			a=x+g[i][0],b=y+g[i][1];
			if(a<=0||a>n||b<=0||b>n){
				continue;
			}
			if(can[a][b]&&!vis[a][b]){
				vis[a][b]=1;
				q.push((node){a,b});
			}
		}
	}
}
void into(){
	int m,a,b,c,d;
	scanf("%d%d",&n,&m);
	can[1][1]=1;
	while(m--){
		scanf("%d%d%d%d",&a,&b,&c,&d);
		add(a,b,c,d);
	}
}
int main(){
	into();
	do{
		last=ans;
		BFS();
	}while(last!=ans);
	printf("%d\n",ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值