hdu3183 RMQ

 

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2742    Accepted Submission(s): 1071

Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

 

Sample Input
178543 4 1000001 1 100001 2 12345 2 54321 2
 

 

Sample Output
13 1 0 123 321

 

/*
hdu3183	RMQ
给你一串数字,求出删除m个数字后的最小值,用其他方法应该很好做的
开始想的是将里面的最大值选出来,但发现并不怎么靠谱,后来参考别人思路
发现可以通过RMQ求出最小值的位置,假设要在n个数中找出m个,那么第一个数一定在
[1,n-m],找出这个数的位置x,那么第二个数则在[x+1,n-m+1]
hhh-2016-01-30 03:13:55	
*/

#include <functional>
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <Map>
using namespace std;
typedef long long ll;
typedef long double ld;

using namespace std;

const int maxn = 1005;
char str[maxn];
char ans[maxn];
int dp[maxn][20];
int mm[maxn];


int Min(int i,int j)
{
    return str[i] <= str[j] ? i:j;
}

void iniRMQ(int n,char c[])
{
    for(int i = 0; i < n; i++)
    {
        dp[i][0] = i;
    }
    for(int j = 1; j <= mm[n]; j++)
    {
        for(int i = 0; i+(1<<j)-1 < n; i++)
            dp[i][j] = Min(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
    }
}

int RMQ(int x,int y)
{
    int k = mm[y-x+1];
    return Min(dp[x][k],dp[y-(1<<k)+1][k]);
}


int main()
{
    int m;
    mm[0] = -1;
    for(int i = 1;i <= 1000;i++)
        mm[i] = ((i&(i-1)) == 0)? mm[i-1]+1:mm[i-1];
    while(scanf("%s%d",str,&m) != EOF)
    {
        int n = strlen(str);
        iniRMQ(n,str);
        int now,tot;
        now = tot = 0;
        m = n-m;
        while(m--)
        {
             now = RMQ(now,n-m-1);
            ans[tot++] = str[now++];
        }
        for(now = 0; now < tot; now++)
            if(ans[now] != '0')
                break;

        if(now == tot)
            printf("0\n");
        else
        {
            while(now < tot)
            {
                printf("%c",ans[now]);
                now ++;
            }
            printf("\n");
        }
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/Przz/p/5409633.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值