6463: Tak and Hotels II

6463: Tak and Hotels II

时间限制: 1 Sec   内存限制: 128 MB
提交: 95   解决: 29
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

N hotels are located on a straight line. The coordinate of the i-th hotel (1≤i≤N) is xi.
Tak the traveler has the following two personal principles:
He never travels a distance of more than L in a single day.
He never sleeps in the open. That is, he must stay at a hotel at the end of a day.
You are given Q queries. The j-th (1≤j≤Q) query is described by two distinct integers aj and bj. For each query, find the minimum number of days that Tak needs to travel from the aj-th hotel to the bj-th hotel following his principles. It is guaranteed that he can always travel from the aj-th hotel to the bj-th hotel, in any given input.

Constraints
2≤N≤105
1≤L≤109
1≤Q≤105
1≤xi<x2<…<xN≤109
xi+1−xi≤L
1≤aj,bj≤N
aj≠bj
N,L,Q,xi,aj,bj are integers.
Partial Score
200 points will be awarded for passing the test set satisfying N≤103 and Q≤103.

输入

The input is given from Standard Input in the following format:
N
x1 x2 … xN
L
Q
a1 b1
a2 b2
:
aQ bQ

输出

Print Q lines. The j-th line (1≤j≤Q) should contain the minimum number of days that Tak needs to travel from the aj-th hotel to the bj-th hotel.

样例输入

9
1 3 6 13 15 18 19 29 31
10
4
1 8
7 3
6 7
8 5

样例输出

4
2
1
2

提示

For the 1-st query, he can travel from the 1-st hotel to the 8-th hotel in 4 days, as follows:
Day 1: Travel from the 1-st hotel to the 2-nd hotel. The distance traveled is 2.
Day 2: Travel from the 2-nd hotel to the 4-th hotel. The distance traveled is 10.
Day 3: Travel from the 4-th hotel to the 7-th hotel. The distance traveled is 6.
Day 4: Travel from the 7-th hotel to the 8-th hotel. The distance traveled is 10.

来源

ABC044&ARC060


 题意:

给 n 个点 , 一天最大的移动距离,要求每天结束时必须在点上,求从A点到B点的最小天数。


思路:

f[x][y] 表示第x个点第2^y天能到达的最远点,二分处理 f[i][0],  那么 f[i][j] = f[f[i][j-1]][j-1](这里,因为j 表示 2的次方数, 所以第i个点 第 2^j 天能到达的最远点为  该点前 2^(j-1) 天能到达的最远点 经过 2^(j-1)天能到的最远点)。

记录一个从A 开始的 cur 值, 找到小于B的第一个值,改变 cur 值。


代码如下:

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
int n,a,b,p[maxn],l,Q;
int f[maxn][35];
int main(){
    scanf("%d",&n);
    for (int i=1; i<=n; i++) scanf("%d",&p[i]);
    scanf("%d",&l);
    for (int i=1;i<=n;i++){
        int idx=upper_bound(p+1,p+1+n,p[i]+l)-p-1;
        if(p[i]+l>=p[n]) f[i][0]=n;
        else f[i][0]=idx;
    }
    for (int j=1; j<=30; j++)
        for (int i=1;i<=n;i++)
            f[i][j]=f[f[i][j-1]][j-1];
    scanf("%d",&Q);
    while(Q--){
        scanf("%d%d",&a,&b);
        if(a>b) swap(a,b);
        int cur=a,ans=0;
        for (int i=30; i>=0; i--){
            if(f[cur][i]<b){
                ans+=(1<<i);
                cur = f[cur][i];
            }
        }
        printf("%d\n",ans+1);
    }
    return 0;
}

转载于:https://www.cnblogs.com/acerkoo/p/9490323.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值