[原]武大预选赛F题-(裸并查集+下标离散化+floyd最短路)

Problem 1542 - F - Countries
Time Limit: 1000MS Memory Limit: 65536KB
Total Submit: 266 Accepted: 36 Special Judge: No
Description
There are n countries at planet X on which Xiao Ming was born.


Some countries, which have been sharing fine bilateral relations, form a coalition and thus all of their citizens will benefit from a policy for which all the travels between these countries will become totally free.

But it is not easy to travel between countries distributed in different coalitions. If possible, it must cost some money called YZB(yu zhou bi) which is always positive.

Help Xiao Ming determine the minimum cost between countries.
Input
The input consists of one or more test cases.

First line of each test case consists two integers n and m. (1<=n<=10^5, 1<=m<=10^5)

Each of the following m lines contains: x y c, and c indicating the YZB traveling from x to y or from y to x. If it equals to zero, that means x and y are in the same coalition. (1<=x, y<=n, 0<=c<=10^9)
You can assume that there are no more than one road between two countries.

Then the next line contains an integer q, the number of queries.(1<=q<=200)

Each of the following q lines contains: x y. (1<=x, y<=n)

It is guaranteed that there are no more 200 coalitions.

Input is terminated by a value of zero (0) for n.
Output
For each test case, output each query in a line. If it is impossible, output “-1”.

Sample Input
6 5
1 2 0
2 4 1
3 5 0
1 4 1
1 6 2
3
4 2
1 3
4 6
0
Sample Output
1
-1

3


AC代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define INF1 1000000000000000001
#define INF2 1000000009
const int maxn = 100010;
struct node{
   int s,e,w;
}map[maxn];
long long d[201][201];
long long fa[maxn];
int n, m;
int h[maxn];
void init(int a)
{
  for(int i = 0; i <= a; i++)
  {
    fa[i] = i;
    h[i] = 0;
  }
  for(int i = 0; i <= a; i++){
     map[i].w = INF2;
  }
}

int Find(int x)
{
  if(fa[x] == x)
   return x;
  else
   return fa[x] = Find(fa[x]);
}

void unite(int x,int y)
{
  x = Find(fa[x]);
  y = Find(fa[y]);

  if(x == y) return;
  else
  {
    if(h[x] > h[y]) fa[y] = fa[x];
    else
    {
      fa[x] = fa[y];
      if(h[x] == h[y]) h[y]++;
    }
  }
}
bool M[maxn];
int s[maxn];
int r;
void discretize(){
    memset(M, false, sizeof(M));
    //memset(s, 0, sizeof(s));
    int k;
    for(int i = 1; i <= n; i++){
      k = Find(i);
      if(!M[k]){
       s[k] = r++;
       M[k] = true;
      }
    }
    for(int i = 1; i < r; i++){
     for(int j = 1; j < r; j++){
       if(i == j) d[i][j] = 0;
       else d[i][j] = INF1;
     }
    }
    for(int j = 1; j <= m; j++){
      if(map[j].w != 0){
       int dx = Find(map[j].s);
       int dy = Find(map[j].e);
       dx = s[dx];
       dy = s[dy];
       d[dx][dy] = d[dy][dx] = min(d[dx][dy],(long long)map[j].w);
       //cout<<"*"<<d[dx][dy]<<"*"<<endl;
      }
    }
}

void floyd(int r){
    for(int k = 1; k < r; k++)
      for(int i = 1; i < r; i++)
        for(int j = 1; j < r; j++){
          if(d[i][k] < INF1 && d[k][j] < INF1) d[i][j] = min(d[i][k] + d[k][j], d[i][j]);
        }
}
void input(int m){
 for(int i = 1; i <= m; i++){
     int a , b;
     scanf("%d%d",&map[i].s, &map[i].e);
     scanf("%d",&map[i].w);
     if(map[i].w == 0) unite(map[i].s, map[i].e);
    }
}

int main(){
   while(cin>>n>>m&&n){
    init(n);
    input(m);

    r = 1;
    discretize();
    floyd(r);

    int q;
    cin>>q;
    while(q--){
     int a, b;
     scanf("%d%d",&a, &b);
     a = Find(a);
     b = Find(b);
     a = s[a];
     b = s[b];
     if(d[a][b] == INF1) printf("-1\n");
     else
       printf("%lld\n",d[a][b]);
    }
   }
}

作者:u011652573 发表于2014-4-1 15:55:37 原文链接
阅读:58 评论:0 查看评论

转载于:https://www.cnblogs.com/ZiningTang/p/3834753.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值