[hdu4300]Clairewd’s message

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    

Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6540    Accepted Submission(s): 2445

Problem Description

Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

Input

The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.

Range of test data:

T<= 100 ;
n<= 100000;
 

Output

For each test case, output one line contains the shorest possible complete text.
 

Sample Input

2

abcdefghijklmnopqrstuvwxyz

abcdab

qwertyuiopasdfghjklzxcvbnm

qwertabcde
 

Sample Output

abcdabcd

qwertabcde
 

Author

BUPT
 

Source

2012 Multi-University Training Contest 1
 

Recommend

zhuyuanchen520   |We have carefully selected several similar problems for you:  4302 4301 4303 4304 4308 

题目大意

是有一份文件,前面是密文,后面是原文,但那个人接到这个文件后不知道中间从哪里开始是原文,所以你要帮忙还原一下,如果后面原文比密文少,你就将它补全, 第一行是密文转换格式,例如第二个样例表示将q翻译成a,w翻译成b。

思路

我们只要先把密文都翻译成明文,然后去比较原来的字符串的后缀和翻译之后的字符串前缀的最长匹配长度就行(注:最长匹配的长度不能超过原长的一半)

View code

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const ULL base=255;
char mp[30],trs[30];
char mes[100100];
ULL s[100100],t[100100],p[100100];int len;
void pre(){
    for(char c='a';c<='z';c++)trs[mp[c-'a']-'a']=c;
    for(int i=1;i<=len;i++){
        s[i]=s[i-1]*base+mes[i];
        t[i]=t[i-1]*base+trs[mes[i]-'a'];
    }
}
ULL gethash(int l,int r,ULL g[]){
    return g[r]-g[l-1]*p[r-l+1];
} 
int main(){
    int T;scanf("%d",&T);
    p[0]=1;for(int i=1;i<=100000;i++)p[i]=p[i-1]*base;
    while(T--){
        scanf("%s%s",mp,mes+1);
        len=strlen(mes+1);
        pre();
        int ans=len;
        for(int i=len;i<len<<1;i++){
            if(i&1)continue;
            int tmp=i>>1;int com=len-tmp;
            ULL s1=gethash(1,com,t);
            ULL s2=gethash(tmp+1,len,s);
            if(s1==s2){ans=tmp;break;}
        }
        for(int i=1;i<=ans;i++)
            printf("%c",mes[i]);
        for(int i=1;i<=ans;i++)
            printf("%c",trs[mes[i]-'a']);
        cout<<endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/Anoxiacxy/p/7018570.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值