poj 1466 Girls and Boys(二分匹配之最大独立集)

Description
In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

 

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

 

Output

For each given data set, the program should write to standard output a line containing the result.

 

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

 

Sample Output

5
2

 

Source

 

题目大意:有n个学生,每个学生都和一些人又关系,现在要你找出最大的人数,使得这些人之间没关系

解题思路:裸的最大独立集,最大独立集=点数-最大匹配数
这里注意因为是两两匹配,所以求出的匹配值要除上个2

优化了几下,时间不断减少

 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 506
int n;
int match[N];
int vis[N];
int mp[N][N];
bool dfs(int x){
    for(int i=0;i<n;i++){
        if(!vis[i] && mp[x][i]){
            vis[i]=1;
            if(match[i]==-1 || dfs(match[i])){
                match[i]=x;
                return true;
            }
        }
    }
    return false;
}
void solve(){
    int ans=0;
    memset(match,-1,sizeof(match));

    for(int i=0;i<n;i++){
        memset(vis,0,sizeof(vis));
        if(dfs(i)){
            ans++;
        }
    }
    printf("%d\n",n-ans/2);
}
int main()
{

    while(scanf("%d",&n)==1){
        memset(mp,0,sizeof(mp));
        char s[6];
        for(int i=0;i<n;i++){
            scanf("%s",s);
            scanf("%s",s);
            int num=0;
            for(int j=0;j<strlen(s);j++){
                if(s[j]>='0' && s[j]<='9'){
                    num=num*10+s[j]-'0';
                }
            }
            //printf("---%d\n",num);
            int x;
            for(int j=0;j<num;j++){
                scanf("%d",&x);
                mp[i][x]=mp[x][i]=1;
            }
        }
        solve();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/UniqueColor/p/4773723.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值