方程式

Consider equations having the following form: a*x1*x1 + b*x2*x2 + c*x3*x3 + d*x4*x4 = 0 a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0. It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}. Determine how many solutions satisfy the given equation.

输入

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.

输出

or each test case, output a single line containing the number of the solutions.

样例输入
1 2 3 -4
1 1 1 1
样例输出
39088
0
#include<iostream>
 #include<cstring>
 using namespace std;
 int f1[1000005];
 int f2[1000005];
 int main()
 {
     long long int  a,b,c,d,sum,i,j,k;
     while(cin>>a>>b>>c>>d)
     {
         if(a>0 && b>0 && c>0 && d>0||a<0 && b<0 && c<0 && d<0)
         {
         cout<<0<<endl;
         continue;
         }
         memset(f1,0,sizeof(f1));
         memset(f2,0,sizeof(f2));
         for(i=1;i<=100;i++)
         {    for(j=1;j<=100;j++)
             {
                k=a*i*i+b*j*j;
                if(k>=0) f1[k]++;
                else f2[-k]++;
             }
         }
         sum=0;
         for(i=1;i<=100;i++)
         {
             for(j=1;j<=100;j++)
             {
               k=c*i*i+d*j*j;
               if(k>0) sum+=f2[k];
               else sum+=f1[-k];
             }
         }
         sum=sum*16;
         cout<<sum<<endl;
     }
    return 0;
 }

 

转载于:https://www.cnblogs.com/Lazy-Cat/p/9838491.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值