hdu 1496 Equations 哈希表

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10163    Accepted Submission(s): 4200


 

Problem Description

Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

 

 

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

 

 

Output

For each test case, output a single line containing the number of the solutions.

 

 

Sample Input

 

1 2 3 -4 1 1 1 1

 

 

Sample Output

 

39088 0

 

 

Author

LL

 

#include <bits/stdc++.h>

using namespace std;
typedef unsigned long long ll;
const int maxn = 1e5 + 100;
const int mod = (1 << 15) - 1;
int head[mod + 100], nexx[maxn], cnt[maxn], val[maxn];
int num;

int Hash(int x) {
    return (x % mod + mod) % mod;
}

void insert(int y) {
    int x = Hash(y);
    for (int i = head[x]; i!=0; i = nexx[i]) {
        if (val[i] == y) {
            cnt[i]++;
            return;
        }
    }
    nexx[num] = head[x];
    val[num] = y;
    cnt[num] = 1;
    head[x] = num++;
}

int search(int y) {
    int x = Hash(y);
    for (int i = head[x]; i!=0; i = nexx[i]) {
        if (val[i] == y) return cnt[i];
    }
    return 0;
}

int main() {
    int a, b, c, d;
    while (~scanf("%d%d%d%d", &a, &b, &c, &d)) {
        if ((a > 0 && b > 0 && c > 0 && d > 0) || (a < 0 && b < 0 && c < 0 && d < 0)) {
            printf("0\n");
            continue;
        }
        memset(head, 0, sizeof(head));
        num = 1;
        int ans = 0;
        for (int x1 = 1; x1 <= 100; x1++) {
            for (int x2 = 1; x2 <= 100; x2++) {
                insert(-a * x1 * x1 - b * x2 * x2);
            }
        }
        for (int x3 = 1; x3 <= 100; x3++) {
            for (int x4 = 1; x4 <= 100; x4++) {
                ans += search(c * x3 * x3 + d * x4 * x4);
            }
        }
        printf("%d\n", ans * 16);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值