浙大pat甲级题目---1028. List Sorting (25)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
这道题就是考排序 注意大家一定要换成printf和scanf输入输出,不然最后一个点会超时。可以看到cin和cout确实慢啊
#include <iostream>
#include <vector>
#include <iomanip>
#include <algorithm>
using namespace std;
struct student
{
    int id;
    string name;
    int grade;
};
vector<student>list;
bool CmpID(student &a,student &b)
{
    if(a.id!=b.id)
        return a.id<b.id;
}
bool CmpName(student &a,student &b)
{
    if(a.name!=b.name)
        return a.name<b.name;
    else
        return a.id<b.id;
}
bool CmpGrade(student &a,student &b)
{
    if(a.grade!=b.grade)
        return a.grade<b.grade;
    else
        return a.id<b.id;
}
int main() {
    int n,c;
    scanf("%d%d",&n,&c);
    //list.resize(n);
    for(int i=0;i<n;i++)
    {
        student temp;
        scanf("%d",&temp.id);
        cin>>temp.name;
        scanf("%d",&temp.grade);
        list.push_back(temp);
    }
    if(c==1)
    {
        sort(list.begin(),list.end(),CmpID);
    }else if(c==2)
    {
        sort(list.begin(),list.end(),CmpName);
    }else if(c==3)
    {
        sort(list.begin(),list.end(),CmpGrade);
    }
    for(int i=0;i<n;i++)
    {
        //cout<<setw(6)<<setfill('0')<<list[i].id;
        //cout<<" "<<list[i].name<<" "<<list[i].grade<<endl;
        printf("%06d %s %d\n", list[i].id, list[i].name.c_str(), list[i].grade);
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/SK1997/p/8645007.html

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、下载 4使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、 4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值