PAT - 甲级 - 1098. Insertion or Heap Sort (25)(排序)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

给定条件:
1.n个数字
2.2行数字,每行n个

要求:
1.输出第二行数字是有第一行数字通过插入排序还是堆排序操作以后得到的
2.输出再操作一次得到的数列

求解:
1.插入排序得到前面数字后序,后面数字顺序和原顺序相同,非插入排序即堆排序
2.插入排序下一步,将后面无序的第一个数字插入到前面有序序列即可
2.堆排序,前面的无序序列是最大堆,第一个元素就是最大的元素,直接插入到有序序列最前面(和最后一个无序元素交换),交换后需要维护最大堆


#include <cstdio>
#include <algorithm>

using namespace std;


int n;
int a[110], b[110];

void Heap(int l, int r) {
	int i = 1, j = i*2;
	while(j <= r) {
		if(j+1 <= r && b[j+1] > b[j]) {
			j = j+1;
		}
		if(b[i] < b[j]) {
			swap(b[i], b[j]);
			i = j;
			j = i * 2;
		} else {
			break;
		}
	}
}

int main() {

	freopen("input.txt", "r", stdin);

	scanf("%d", &n);
	a[0] = b[0] = 0;
	for(int i = 1; i <= n; i++) {
		scanf("%d", &a[i]);
	}
	for(int i = 1; i <= n; i++) {
		scanf("%d", &b[i]);
	}


	int p = 1;

	while(p <= n && b[p] >= b[p-1]) p++;
	int end = p;
	while(p <= n && b[p] == a[p])   p++;

	if(p == n+1) {
		printf("Insertion Sort\n");
		sort(b+1, b+end+1);
		for(int i = 1; i <= n; i++) {
			if(i != 1) printf(" ");
			printf("%d", b[i]);
		}
	} else {
		printf("Heap Sort\n");
		p = n;
		while(p >= 2 && b[p] > b[p-1]) p--;
		swap(b[1], b[p]);
		Heap(1, p-1);
		for(int i = 1; i <= n; i++) {
			if(i != 1) printf(" ");
			printf("%d", b[i]);
		}
	}	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值