ACM hdu 1019 Least Common Multiple

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
 
     
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
 
     
105 10296
/***********************

简单数学题,求连续n个数的最小公倍数

**************************/

Code:

#include <iostream>
#include<string.h>
using namespace std;
int a[10000];
int gcd(int a,int b)//求最大公约数
{
    int temp;
    if(a<b)
    {
        temp = a;a = b;b = temp;
    }
    return (b==0)?a:gcd(b,a%b);
}
int LCM(int a,int b)//求最小公倍数
{
    return a/gcd(a,b)*b; //开始写成 a*b/gcd(a,b),WA了两次,因为可能会溢出
}
int main()
{
    int T,n,ans,x;
    cin>>T;
    while(T--)
    {
        //memset(a,0,sizeof(a));
        ans = 1;
        cin>>n>>x;
        ans = LCM(ans,x);
        for(int i = 0;i<n-1;i++)
        {
            cin>>x;
            ans = LCM(ans,x);
        }
        cout<<ans<<endl;
    }

    return 0;
}




posted on 2014-04-09 19:38  CY_ 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/gray1566/p/3704317.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值