ACM HDU Primes(素数判断)

Problem Description

Writea program to read in a list of integers and determine whether or not eachnumber is prime. A number, n, is prime if its only divisors are 1 and n. Forthis problem, the numbers 1 and 2 are not considered primes. 

 

 

Input

Eachinput line contains a single integer. The list of integers is terminated with anumber<= 0. You may assume that the input contains at most 250 numbers andeach number is less than or equal to 16000.

 

 

Output

Theoutput should consists of one line for every number, where each line firstlists the problem number, followed by a colon and space, followed by"yes" or "no". 

 

 

Sample Input

1

2

3

4

5

17

0

 

 

Sample Output

1: no

2: no

3: yes

4: no

5: yes

6: yes

 

/************************************************************************

简单数论,判断素数,,,

**************************************************/


#include<stdio.h>
bool prime(int n)
{
	if(n<=2)
		return false;//  这题好奇葩, 1,2不算素数
	for(int i = 2;i*i<=n;i++)
		if(n%i==0)
			return false;
	return true;
}
int main()
{
	int n,count = 0;//  注意输出时前面的数字是计数的,而不是输入的数字
	while(scanf("%d",&n)&&n>0)
	{
		count++;
		if(prime(n))
			printf("%d: yes\n",count);
		else
			printf("%d: no\n",count);
	}
	return 0;
}

//  虽然很简单,但是想记下来,慢慢积累。。
posted on 2014-03-28 19:29  CY_ 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/gray1566/p/3704297.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值