c++ 简单二维空间的点类

Problem Description
定义点类Point,其中有数据成员x和y,表示点的横坐标与纵坐标。
成员函数double distance(const Point &)的功能是求两点之间的距离。
成员函数void inputPoint()的功能是从键盘输入点的x、y坐标值。
//你的代码将被嵌在这里
int main()
{
Point a, b;
a.inputPoint();
b.inputPoint();

cout << a.distance(b);

return 0;

}

Sample Input
0 0
3 4
Sample Output
5

#include <iostream>
using namespace std;
#include <cmath>

class Point
{
   
public:
    double x, y;
    /*Point(int a, int b)
    {
        x = a;
        y = b;
    }*/
    void inputPoint()
    {
   
        cin >> x >> y;
    }
    double distance(
  • 2
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值