zoj 2736 水仙花

Daffodil number

Time Limit: 1 Second       Memory Limit: 32768 KB

The daffodil number is one of the famous interesting numbers in the mathematical world. A daffodil number is a three-digit number whose value is equal to the sum of cubes of each digit.

For example. 153 is a daffodil as 153 = 13 + 53 + 33.

Input

There are several test cases in the input, each case contains a three-digit number.

Output

One line for each case. if the given number is a daffodil number, then output "Yes", otherwise "No".

Sample Input

153
610

Sample Output

Yes
No

ZOJ <wbr>2736 <wbr>Daffodil <wbr>number
 
   
#include < iostream >
using namespace std;

bool judge( int num){
int a, b, c, fb = num;
a
= fb % 10 ; fb /= 10 ;
b
= fb % 10 ; fb /= 10 ;
c
= fb;
if (a * a * a + b * b * b + c * c * c == num)
return true ;
else return false ;
}
int main()
{
int num;
while (cin >> num){
if (judge(num))
cout
<< " Yes " << endl;
else cout << " No " << endl;
}
return 0 ;
}

转载于:https://www.cnblogs.com/laipDIDI/articles/2042941.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值