7-5 玩转二叉树

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2
#include <bits/stdc++.h>
#define debug cout << " *** " << endl;
using namespace std;
typedef struct node
{
    int data;
    struct node *lson, *rson;
} *bitree, bitnode;
bitree build(int preorder[],int inorder[],int i)
{
	if(!i) return NULL;
	bitree root = new bitnode;
	root->data = preorder[0];
	root -> lson = root -> lson = NULL;
	int idx = 0;
	for(;idx < i ; idx++)
	{
		if(inorder[idx] == preorder[0]) break;
	}
	root -> lson = build(preorder+1,inorder,idx);
	root -> rson = build(preorder+1+idx,inorder+idx+1,i-idx-1);
	return root;
}
void mirrortree(bitree root)
{
    if(!root) return;
    swap(root->lson,root->rson);
    mirrortree(root->lson);
    mirrortree(root->rson);
}
void levelorder(bitree root)
{
    bool flag = true;
    if(!root) return;
    queue<bitree>q;
    q.push(root);
    while(!q.empty())
    {
        bitree curr = q.front();
        q.pop();
        if(flag)
        cout << curr->data;
        else cout << " " << curr->data;
        flag = false;
        if(curr->lson) q.push(curr->lson);
        if(curr->rson) q.push(curr->rson);
    }
}
int main()
{
    int n;
    int inorder[35], preorder[35];
    cin >> n;
    for (int i = 0; i < n; i++)
        cin >> inorder[i];
    for (int i = 0; i < n; i++)
        cin >> preorder[i];
    bitree root = new bitnode;
    root = build(preorder,inorder,n);
    mirrortree(root);
    levelorder(root);
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值