poj1251 Jungle Roads

题目题目题目:

2:Jungle Roads
查看 提交 统计 提问
总时间限制: 1000ms 内存限制: 65536kB
描述

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

输入
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
输出
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
样例输入
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
样例输出
216
30
来源
Mid-Central USA 2002


用Prim算法求最小生成树(Minimum-cost Spanning Tree, MST)。可以看出Prim算法和Dijkstra算法在框架上是相同的,唯一的区别就是:在抽取出权值最小的边之后,Dijkstra算法对这个边进行松弛操作,Prim算法直接将这个边纳入MST然后都将这条边的所有未访问邻接边储存起来备用。


代码清单:

//Prim算法生成Minimum-cost Spanning Tree(MST)
//图的储存方式还是用我目前熟悉的邻接矩阵
#include <iostream>
#include <string>
using namespace std;

#define INFINITE 1000000
#define MAXN 26
#define MAXR 75	//最大路径数目

typedef struct _edge
{
	int begin_vertex;
	int end_vertex;
	int length;
} edge;

int dist[MAXN][MAXN];
int visited[MAXN];
edge edge_store[MAXR];

void init(int n)
{
	//初始化邻接矩阵
	for (int i=0; i<n; ++i)
	{
		for (int j=0; j<n; ++j)
		{
			dist[i][j]=INFINITE;	//孤立的点,没有通路
		}
	}
	for (int i=0; i<n; ++i)
	{
		dist[i][i]=0;	//自己到自己的距离是0
	}

	//初始化visited数组
	for (int i=0; i<n; ++i)
	{
		visited[i]=0;	//0没被访问,1已被访问
	}

	//初始化edge数组
	for (int i=0; i<MAXR; ++i)
	{
		edge_store[i].begin_vertex=-1;
		edge_store[i].end_vertex=-1;
		edge_store[i].length=INFINITE;
	}
}

void build_graph(int n)
{
	string str;
	char str_c;
	int to_count, from, to, d;

	for (int i=0; i<n-1; ++i)
	{
		cin>>str;
		cin>>to_count;

		str_c=str[0];
		from=str_c-'A';

		for (int j=0; j<to_count; ++j)
		{
			cin>>str;
			cin>>d;

			str_c=str[0];
			to=str_c-'A';

			dist[from][to]=d;
			dist[to][from]=d;
		}
	}
}

//prim算法核心代码
int extract_min(int size)	//抽取长度最短的边
{
	int min_len=INFINITE;
	int v=-1;
	for (int i=0; i<size; ++i)
	{
		if (visited[edge_store[i].end_vertex]==0 && edge_store[i].length<min_len)	//没有访问过且边的长度更短
		{
			min_len=edge_store[i].length;
			v=i;
		}
	}
	return v;
}

int run_prim(int n)
{
	int mtw=0;	//最小权值总和
	visited[0]=1;	//始终从A点开始迭代
	int k=0, e;

	int current_from=0;
	for (int i=0; i<n-1; ++i)	//要添加(n-1)条边
	{
		for (int j=0; j<n; ++j)	//储存当前顶点的所有邻接边
		{
			if (dist[current_from][j]<INFINITE && visited[j]==0)	//连通且没有访问的邻接边
			{
				edge_store[k].begin_vertex=current_from;
				edge_store[k].end_vertex=j;
				edge_store[k].length=dist[current_from][j];
				++k;
			}
		}

		e=extract_min(k);	//取出长度最小的邻接边在数组中的下标
		mtw+=edge_store[e].length;	//累加到路径总长中
		visited[edge_store[e].end_vertex]=1;	//边的终点标记为已访问

		current_from=edge_store[e].end_vertex;	//下一个起点就是当前的终点
	}

	return mtw;
}

int main()
{
	//freopen("D:\\in.txt", "r", stdin);  
	//freopen("D:\\out.txt", "w", stdout);  

	int n, mtw;
	
	while (1)
	{
		cin>>n;
		if (n==0) break;

		init(n);
		build_graph(n);
		mtw=run_prim(n);

		cout<<mtw<<endl;
	}

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值