Convoy (二分)

You and your friends have gathered at your house to prepare for the Big Game, which you all plan to attend in the afternoon at the football stadium across town. The problem: you only have k cars between you, with each car seating five people (including the driver), so you might have to take multiple trips to get all n people to the stadium. In addition, some of your friends know the city better than others, and so take different amounts of time to drive to the stadium from your house. You’d like to procrastinate as long as possible before hitting the road: can you concoct a transportation plan that gets all people to the stadium in the shortest amount of time possible?

More specifically, each person i currently at your house can drive to the stadium in ti minutes. All k cars are currently parked at your house. Any person can drive any car (so the cars are interchangeable). After a car arrives at the stadium, any person currently at the stadium can immediately start driving back to your house (and it takes person i the same amount of time ti to drive back as to drive to the stadium), or alternatively, cars can be temporarily or permanently parked at the stadium. Drivers driving to the stadium can take up to four passengers with them, but drivers driving back can NOT take any passenger. You care only about getting all n people from your house to the stadium—you do NOT need to park all k cars at the stadium, if doing so would require more time than an alternative plan that leaves some cars at your house.

Input
The first line of input contains two space-separated integers n and k (1≤n,k≤20000), the number of people at your house and the number of available cars. Then follow n lines containing a single integer each; the ith such integer is the number of seconds ti (1≤ti≤1000000) that it takes person i to drive from your house to the stadium, or vice-versa.

Output
Print the minimum number of seconds it takes to move all n people from your house to the stadium, if all people coordinate and drive optimally.

Sample Input 1 Sample Output 1
11 2
12000
9000
4500
10000
12000
11000
12000
18000
10000
9000
12000
13500
Sample Input 2 Sample Output 2
6 2
1000
2000
3000
4000
5000
6000
2000

二分,不过有一点比较坑,注意处理k>n,会有除以零的情况

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const LL N = 2e6 + 10;
LL a[N], n, m = 0, k;
LL check(LL x) {
    LL s = 0;
    for (LL i = 0; i < m; i++) {
        if (x >= a[i])
            s += (x / a[i] / 2 + x / a[i] % 2) * 4 + 1;
        else
            break;
    }
    if (s >= n) return 1;
    return 0;
}
int main() {
    cin >> n >> k;
    m = min(n, k);
    for (LL i = 0; i < n; i++) cin >> a[i];
    sort(a, a + n);
    LL l = 0, r = 1e12;
    LL ans = r;
    while (l <= r) {
        LL mid = (l + r) / 2;
        if (check(mid)) {
            ans = min(ans, mid);
            r = mid - 1;
        } else
            l = mid + 1;
    }
    cout << ans << '\n';
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值