POJ 3268 Silver Cow Party (最短路dijkstra)

Silver Cow Party

题目链接:

http://acm.hust.edu.cn/vjudge/contest/122685#problem/D

Description


One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input


Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output


Line 1: One integer: the maximum of time any one cow must walk.

Sample Input


4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output


10

Hint


Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


题意:


n个人分别住在1~n个点,他们要去某个点聚会并且结束后返回家中.
求每个人的最短路程. (往返路径可以不一样).


题解:


先用dijkstra求出终点到所有点的最短路径(返程).
再沿着反向路径跑一次dijkstra,求出所有点到终点的最短路径.


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define mid(a,b) ((a+b)>>1)
#define LL long long
#define maxn 1010
#define inf 0x3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std;

int n,m;
int value[maxn][maxn];
int dis[maxn];
bool vis[maxn];
int dis2[maxn];

void dijkstra(int s) {
    memset(vis, 0, sizeof(vis));
    for(int i=1; i<=n; i++) dis[i] = inf;
    dis[s] = 0;

    for(int i=1; i<=n; i++) {
        int p, mindis = inf;
        for(int j=1; j<=n; j++) {
            if(!vis[j] && dis[j]<mindis)
                mindis = dis[p=j];
        }
        vis[p] = 1;
        for(int j=1; j<=n; j++) {
            if(dis[j] > dis[p]+value[p][j]) {
                dis[j] = dis[p] + value[p][j];
            }
        }
    }
}

void dijkstra2(int s) {
    memset(vis, 0, sizeof(vis));
    for(int i=1; i<=n; i++) dis2[i] = inf;
    dis2[s] = 0;

    for(int i=1; i<=n; i++) {
        int p, mindis = inf;
        for(int j=1; j<=n; j++) {
            if(!vis[j] && dis2[j]<mindis)
                mindis = dis2[p=j];
        }
        vis[p] = 1;
        for(int j=1; j<=n; j++) {
            if(dis2[j] > dis2[p]+value[j][p]) {
                dis2[j] = dis2[p] + value[j][p];
            }
        }
    }
}

int main(int argc, char const *argv[])
{
    //IN;

    int aim;
    while(scanf("%d %d %d", &n,&m,&aim) != EOF)
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                value[i][j] = inf;
        while(m--){
            int u,v,w; cin>>u>>v>>w;
            if(w < value[u][v]) value[u][v] = w;
        }

        dijkstra(aim);
        dijkstra2(aim);

        int ans = 0;
        for(int i=1; i<=n; i++) if(dis[i]!=inf && dis2[i]!=inf)
            ans = max(ans, dis[i]+dis2[i]);

        printf("%d\n", ans);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5751314.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值