POJ 1860 Currency Exchange (bellman-ford判负环)

Currency Exchange

题目链接:

http://acm.hust.edu.cn/vjudge/contest/122685#problem/E

Description


Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input


The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output


If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input


3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output


YES

Hint



题意:


给出两种货币之间的汇率及税价.
求能否经过一定的兑换过程使得价值增加.


题解:


抽象成图模型,兑换途径即为路径.
问题转换为判断图中是否存在一个正环.
直接用bellman-ford判负环的方法即可.
注意初始状态:dis[start] = 初始时的钱.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <set>
#define LL long long
#define eps 1e-8
#define maxn 310
#define inf 0x3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std;

int sign(double x){
    if(fabs(x)<eps) return 0;
    return x<0? -1:1;
}

int m,n,s;
double cur;
int edges, u[maxn], v[maxn];
double rate[maxn], cost[maxn];
int first[maxn], next[maxn];
//初始化edge和first
double dis[maxn];

void add_edge(int s, int t, double a, double b) {
    u[edges] = s; v[edges] = t;
    rate[edges] = a; cost[edges] = b;
    next[edges] = first[s];
    first[s] = edges++;
}

bool bellman(int s) {
    for(int i=1; i<=n; i++) dis[i] = -1;
    dis[s] = cur;  //!!!

    for(int i=1; i<=n; i++) {
        for(int e=0; e<edges; e++) {
            double tmp = (dis[u[e]]-cost[e])*rate[e];
            if(sign(dis[v[e]]-tmp) < 0) {
                dis[v[e]] = tmp;
                if(i == n) return 0;
            }
        }
    }

    return 1;
}

int main(int argc, char const *argv[])
{
    //IN;

    while(scanf("%d %d %d %lf", &n,&m,&s,&cur) != EOF)
    {
        memset(first, -1, sizeof(first));
        edges = 0;

        for(int i=1; i<=m; i++) {
            int u,v; double ra,rb,ca,cb;
            scanf("%d %d %lf %lf %lf %lf", &u,&v,&ra,&ca,&rb,&cb);
            add_edge(u,v,ra,ca);
            add_edge(v,u,rb,cb);
        }

        if(!bellman(s)) puts("YES");
        else puts("NO");
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5751394.html

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值