POJ 3159 Candies (栈优化spfa)

Candies

题目链接:

http://acm.hust.edu.cn/vjudge/contest/122685#problem/J

Description


During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.
snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input


The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output


Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input


2 2
1 2 5
2 1 4

Sample Output


5

Hint


32-bit signed integer type is capable of doing all arithmetic.


题意:


求图中#1到#N的最短路.


题解:


题是很裸的最短路,但是数据非常大.
队列形式的spfa会TLE.
这里需要用栈来优化spfa.
事实上,在不需要判断负环的情况下,栈实现spfa比队列要快. (涨姿势了)


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <vector>
#define LL long long
#define eps 1e-8
#define maxn 200000
#define inf 0x3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std;

int m,n,k;
int edges, u[maxn], v[maxn], w[maxn];
int first[maxn], next[maxn];
int dis[maxn];

void add_edge(int s, int t, int val) {
    u[edges] = s; v[edges] = t; w[edges] = val;
    next[edges] = first[s];
    first[s] = edges++;
}

//queue<int> q;
int Q[maxn];
bool inq[maxn];
int inq_cnt[maxn];
bool spfa(int s) {
    int top = 0;
    memset(inq, 0, sizeof(inq));
    memset(inq_cnt, 0, sizeof(inq_cnt));
    for(int i=1; i<=n; i++) dis[i] = inf; dis[s] = 0;
    //while(!q.empty()) q.pop();
    //q.push(s);
    inq_cnt[s]++;
    Q[top++] = s;


    while(top) {
        int p = Q[--top];
        inq[p] = 0;
        for(int e=first[p]; e!=-1; e=next[e]) if(dis[v[e]] > dis[p]+w[e]){
            dis[v[e]] = dis[p] + w[e];
            if(!inq[v[e]]) {
                //q.push(v[e]);
                Q[top++] = v[e];
                inq[v[e]] = 1;
                inq_cnt[v[e]]++;
                //if(inq_cnt[v[e]] >= n) return 0;
            }
        }
    }

    return 1;
}

int main(int argc, char const *argv[])
{
    //IN;

    /*
        spfa+stack  用queue会TLE
    */

    while(scanf("%d %d",&n,&m) != EOF)
    {
        edges = 0;
        memset(first, -1, sizeof(first));
        for(int i=1; i<=m; i++) {
            int u,v,w; scanf("%d %d %d",&u,&v,&w);
            add_edge(u,v,w);
        }

        spfa(1);

        printf("%d\n", dis[n]);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5751549.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值