HDU 5858 Hard problem (数学推导)

Hard problem

题目链接:

http://acm.split.hdu.edu.cn/showproblem.php?pid=5858

Description


cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?
764119-20160818172426750-377270246.png
Give you the side length of the square L, you need to calculate the shaded area in the picture.
The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.

Input


The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).

Output


For each test case, print one line, the shade area in the picture. The answer is round to two digit.

Sample Input


1
1

Sample Output


0.29

Source


2016 Multi-University Training Contest 10


题意:


求阴影面积.


题解:


本渣不会算,只好百度搜图...
(http://f.hiphotos.baidu.com/zhidao/pic/item/83025aafa40f4bfbde8267a0024f78f0f63618f7.jpg)
(http://zhidao.baidu.com/question/571519797?&oldq=1)


764119-20160818172723937-1109865998.png


代码:

/注释部分的公式也可以/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
#define LL long long
#define eps 1e-8
#define maxn 110
#define mod 100000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int main(int argc, char const *argv[])
{
    //IN;

    int t; cin >> t;
    while(t--)
    {
        double a; scanf("%lf", &a);

        //double ans = a*a/4.0 * asin(sqrt(14.0)/4.0);
        //ans -= a*a * asin(sqrt(14.0)/8.0);
        //ans += a*a * sqrt(7.0) / 8.0;
        //ans *= 2.0;

        double ans = atan(sqrt(7.0)) / 4.0;
        ans -= atan(sqrt(7.0)/5.0);
        ans += sqrt(7.0) / 8.0;
        ans *= a*a*2.0;

        printf("%.2f\n", ans);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5784732.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值