POJ 1380 Equipment Box (暴力枚举)

Equipment Box

题目链接:

http://acm.hust.edu.cn/vjudge/contest/130510#problem/B

Description


There is a large room in the Pyramid called Room-of-No-Return. Its floor is covered by rectangular tiles of equal size. The name of the room was chosen because of the very high number of traps and mechanisms in it. The ACM group has spent several years studying the secret plan of this room. It has made a clever plan to avoid all the traps. A specially trained mechanic was sent to deactivate the most feared trap called Shattered Bones. After deactivating the trap the mechanic had to escape from the room. It is very important to step on the center of the tiles only; he must not touch the edges. One wrong step and a large rock falls from the ceiling squashing the mechanic like a pancake. After deactivating the trap, he realized a horrible thing: the ACM plan did not take his equipment box into consideration. The box must be laid onto the ground because the mechanic must have both hands free to prevent contact with other traps. But when the box is laid on the ground, it could touch the line separating the tiles. And this is the main problem you are to solve.

Input


The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case consists of a single line. The line contains exactly four integer numbers separated by spaces: A, B, X and Y. A and Bindicate the dimensions of the tiles, X and Y are the dimensions of the equipment box (1 <= A,B,X,Y <= 50000).

Output


Your task is to determine whether it is possible to put the box on a single tile -- that is, if the whole box fits on a single tile without touching its border. If so, you are to print one line with the sentence "Escape is possible.". Otherwise print the sentence "Box cannot be dropped.".

Sample Input

2
10 10 8 8
8 8 10 10

Sample Output

Escape is possible.
Box cannot be dropped.

Source


2016-HUST-线下组队赛-5


题意:


判断一个小矩形能否放入一个大矩形.


题解:


横着和竖着的情况很容易判断.
关键在于斜着放的情况:可以直接暴力枚举小矩形的旋转角.
数据量比较大,一开始用0.01的差值T掉了.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <queue>
#define maxn 101000
#define inf 0x3f3f3f3f
#define pi acos(-1.0)
#define mod 1000000007
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int a,b,A,B;
bool solve() {
    for(double arg=0; arg<=90.0; arg+=0.1) {
        double p = arg*pi / 180.0;
        double t1 = b*sin(p) + a*cos(p);
        double t2 = a*sin(p) + b*cos(p);
        if(t1 < A && t2 < B) return 1;
    }
    return 0;
}

int main()
{
    //IN;

    int T;
    cin >> T;
    while (T--){
        scanf("%d %d %d %d",&A,&B,&a,&b);
        if(A > B) swap(A,B);
        if(a > b) swap(a,b);

        bool flag = 0;
        if(a < A && b < B) flag = 1;

        if(solve()) flag = 1;

        if(flag) printf("Escape is possible.\n");
        else printf("Box cannot be dropped.\n");
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5816375.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值