poj2549--Sumsets (sum)

Sumsets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9983 Accepted: 2731

Description

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

5
2 
3 
5 
7 
12
5
2 
16 
64 
256 
1024
0

Sample Output

12
no solution

Source

 
转化成 a+b=c-d;
#include <cstdio>
#include <algorithm>
#define M 1010
using namespace std;
int num[M];
int main()
{
    int n;
    while(scanf("%d", &n) != EOF &&n!=0)
    {
        for(int i=0; i<n; i++)
            scanf("%d", &num[i]);
        sort(num, num+n);
        int re; bool flag=1;
        for(int i=n-1; i>=0; i--)
        {
            for(int j=n-1; j>=0; j--)
            {
                if(i==j)
                    continue;
                int multiply=num[i]-num[j];
                int rear=0, top= j-1;   //注意 top取值范围 ; 
                while(rear<top)
                {
                    if(multiply==num[rear]+num[top])
                    {
                        re=num[i];    flag=0;
                    }
                    if(multiply>num[rear]+num[top])
                        rear++;
                    if(multiply<num[rear]+num[top])
                        top--;
                    if(!flag) break;                    
                }
                if(!flag) break; 
            }
            if(!flag) break;
        }
        if(flag)
            printf("no solution\n");
        else
            printf("%d\n", re);
    }
    return 0;    
} 

 

转载于:https://www.cnblogs.com/soTired/p/5326075.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值