POJ 2549 Sumsets(折半枚举)

Sumsets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9892 Accepted: 2705

Description

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

 
 
5
2
3
7
5 12
16
5 2
256
64 1024
0

Sample Output

 
 
12
no solution


题意:在集合S中有n个数,找到最大的d,且d满足于集合内a+b+c=d。


题解:我们把找a+b+c=d化为找 a+b=d-c。设c为a,b,c中最大的元素。  注意d不一定比c大,d-c可以为负数。 这样我们枚举d,c,利用二分的思想查找a,b。 


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f 
using namespace std;
int a[1010];
int main()
{
	int n,i,j;
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;++i)
			scanf("%d",&a[i]);
		sort(a,a+n);
		int ans=INF,cnt;
		for(i=n-1;i>=0;--i)
		{
			for(j=n-1;j>=0;--j)
			{
				if(i==j)
					continue;
				cnt=a[i]-a[j];
				for(int l=0,r=j-1;l<r;)
				{
					if(a[l]+a[r]==cnt)
					{
						ans=a[i];
						break;
					}
					if(a[l]+a[r]>cnt)
						r--;
					else
						l++;
				}
				if(ans!=INF)
					break; 
			}
			if(ans!=INF)
				break;
		}
		if(ans!=INF)
			printf("%d\n",ans);
		else
			printf("no solution\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值