UVA 442

 Matrix Chain Multiplication 

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

 

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

 

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

 

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

 

The second part of the input file strictly adheres to the following syntax (given in EBNF):

 

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

 

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

 

Sample Input

 

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

 

Sample Output

 

0
0
0
error
10000
error
3500
15000
40500
47500
15125
题目理解:

用结构体储存矩形的信息。然后想法和括号的想法相同。!=‘)’,则s.push。若==‘)’。则取出两个 s.top ( )。切记先取出的是第二个矩形。先进后出。然后比较两个的 行和列

然后计算,别忘了更新top

AC代码:

 

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <stack>
#include <vector>

using namespace std;

struct Matrix//定义矩阵结构体
{
    char ch;
    int row, cul;
}matrix[55];

int Case, cmp1, cmp2, ans;
char rec[100], tmp1, tmp2, tmp;

int main ( ) 
{
    scanf ( "%d", &Case  );
    for ( int i = 0; i < Case; ++i ) 
    {
        scanf ( "%c", &matrix[i].ch );
        getchar ( );//不能漏掉
        scanf ( "%d%d", &matrix[i].row, &matrix[i].cul );
        getchar ( );//不能漏掉
    }
    while ( fgets ( rec, 100, stdin ) != NULL ) 
    {
        tmp = Case;
        //printf ( "00\n" );
        //puts ( rec );
        ans = 0;
        int len = strlen ( rec );
        rec[len--] = '\0';
        stack < char > s;
        for ( int i = 0; rec[i] != '\0'; ++i ) 
        {
            if ( rec[i] != ')' ) //和括号匹配的思想一样
                s.push ( rec[i] );
            if ( rec[i] == ')' ) 
            {
                tmp2 = s.top ( );
                s.pop ( );
                tmp1 = s.top ( );
                s.pop ( );
                s.pop ( );
                cmp1 = tmp1 - 'A';
                cmp2 = tmp2 - 'A';
                if ( matrix[cmp1].cul == matrix[cmp2].row ) //矩阵的运算
                {
                    ans += matrix[cmp1].row * matrix[cmp1].cul * matrix[cmp2].cul;
                    matrix[tmp].row = matrix[cmp1].row;
                    matrix[tmp].cul = matrix[cmp2].cul;
                    matrix[tmp].ch = tmp + 'A';
                    s.push ( matrix[tmp].ch );
                    tmp++;
                }
                else 
                {
                    printf ( "error\n" );
                    ans = -1;
                    break;
                }
            }
        }
        if ( ans != -1 )
            printf ( "%d\n", ans );
    }
    return 0;
}
View Code

 

 

 

转载于:https://www.cnblogs.com/LOB104-zhanglei/articles/3195635.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值