HDU 1061-Rightmost Digit

题目

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67183    Accepted Submission(s): 25198

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2 3 4

Sample Output

7 6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1061

思路

题意大概就是 求 $n^{n}$ 的最后一位数。

有两个思路,一个是找规律,另一个是用快速幂

找规律:

0的n次方尾数还是0,1的n次方尾数还是1,5的n次方尾数还是5,6的n次方同样是6。

2的n次方位数为{6,2,4,8}以此类推。

因为尾数是固定的,所以说0~9都是可以推出来的。

然后根据指数n,取余,得到结果。

快速幂:

快速幂这就不用说了,老江湖了。

根据下边的这个公式,我们只用算最后一位数的n次方即可。

$(n^n)mod\ p = ((n\ mod\ p)^{n})mod\ p$

AC代码在下方。

代码

快速幂解决代码

#include<cstdio>

using namespace std;
const int MOD = 10;
#define mod(x) ((x)%MOD)

int poww(int a,int b){
    int res = 1,base=a;
    while(b){
        if(b&1)res = mod(res*base);
        base = mod(base*base);
        b >>= 1;
    }
    return res;
}

int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        printf("%d\n",poww(mod(n),n));
    }
    return 0;
}

找规律

#include<cstdio>

using namespace std;
const int MOD = 10;
#define mod(x) ((x)%MOD)

int a[10][4] = {{0},{1},{6,2,4,8},{1,3,9,7},{6,4},{5},{6},{1,7,9,3},{6,8,4,2},{1,9}};

int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);

        int t = mod(n);

        if(t == 0||t == 1||t == 5||t == 6){

        }else if(t == 4||t == 9){
            t = a[t][n%2];
        }else{
            t = a[t][n%4];
        }
        printf("%d\n",t);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yjz6/p/9799604.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值