HDU 1060 Leftmost Digit

 Leftmost Digit

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, you should output the leftmost digit of N^N. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

Output

For each test case, you should output the leftmost digit of N^N. 
 

Sample Input

    
    
2 3 4
 

Sample Output

    
    
2 2

Hint

 In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2. 
         
 


大致题意:给你一个n,求n ^ n的最高位的数值是多少

分析:用科学计数法表示n ^ n = a * 10 ^ b;

则[a] 即为所求结果。例如4 ^ 4 = 256 = 2.56 * 10 ^ 2;   [2.56] = 2即为所求结果

两边同时取以10为底的对数:lg(n ^ n) = lg(a * 10 ^ b) 化简得:n * lg(n) = lg(a) + b   ->  a = 10 ^ (n * lg(n) - b)

又因为b为n ^ n 的位数,所以b = [n * lg(n)];

a = 10 ^ (n * lg(n) - [n * lg(n)]);

[a] 即为所求结果。

代码如下:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>

using namespace std;

int main()
{
    int t;
    double n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&n);
        double x = n * log10(n) - (long long)(n * log10(n));
        printf("%d\n",int(pow(10,x)));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值