Leftmost Digit
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2 3 4
Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
分析:用科学计数法表示n ^ n = a * 10 ^ b;
则[a] 即为所求结果。例如4 ^ 4 = 256 = 2.56 * 10 ^ 2; [2.56] = 2即为所求结果
两边同时取以10为底的对数:lg(n ^ n) = lg(a * 10 ^ b) 化简得:n * lg(n) = lg(a) + b -> a = 10 ^ (n * lg(n) - b)
又因为b为n ^ n 的位数,所以b = [n * lg(n)];
a = 10 ^ (n * lg(n) - [n * lg(n)]);
[a] 即为所求结果。
代码如下:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int t;
double n;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&n);
double x = n * log10(n) - (long long)(n * log10(n));
printf("%d\n",int(pow(10,x)));
}
return 0;
}